package/wireshark: add lua optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 31 Oct 2018 22:56:47 +0000 (23:56 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 2 Nov 2018 20:43:22 +0000 (21:43 +0100)
- lua 5.3 or luajit is not supported
- Don't specify the path to find lua as pkgconfig is used for lua
  (this is not the case for the other options)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/wireshark/wireshark.mk

index 4569a86cb1ccb89f2b89cf26dd0e8e475c240c0b..421338f0f8b72d603169f01627476fbf720ae995 100644 (file)
@@ -22,7 +22,6 @@ WIRESHARK_CONF_OPTS = \
        --without-krb5 \
        --enable-static=no \
        --with-libsmi=no \
-       --with-lua=no \
        --with-pcap=$(STAGING_DIR)/usr \
        --includedir=$(STAGING_DIR)/usr/include
 
@@ -99,6 +98,14 @@ else
 WIRESHARK_CONF_OPTS += --without-libssh
 endif
 
+# no support for lua53 yet
+ifeq ($(BR2_PACKAGE_LUA_5_1)$(BR2_PACKAGE_LUA_5_2),y)
+WIRESHARK_CONF_OPTS += --with-lua
+WIRESHARK_DEPENDENCIES += lua
+else
+WIRESHARK_CONF_OPTS += --without-lua
+endif
+
 ifeq ($(BR2_PACKAGE_SBC),y)
 WIRESHARK_CONF_OPTS += --with-sbc=yes
 WIRESHARK_DEPENDENCIES += sbc