nettle: disable assembly optimizations for ARMv7M
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 25 Jul 2016 00:15:59 +0000 (21:15 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 25 Jul 2016 20:47:47 +0000 (22:47 +0200)
It's thumb2-only and it requires ARM instructions.
Since V4 and V5 aren't enough either use the V7M knob to avoid
over-complicating the conditional. Fixes:
http://autobuild.buildroot.net/results/354/35418d33efa902d3a1a82b2cd58d8db1b1172e49/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nettle/nettle.mk

index c133839e521cb54ba5334ca2be97f9fbf9eb6a7d..a94a7fc3dfcaefa6fbf3b1cfec2dadf898468651 100644 (file)
@@ -15,7 +15,7 @@ NETTLE_LICENSE_FILES = COPYING.LESSERv3 COPYINGv2
 NETTLE_CONF_OPTS = --disable-openssl
 
 # ARM assembly requires v6+ ISA
-ifeq ($(BR2_ARM_CPU_ARMV4)$(BR2_ARM_CPU_ARMV5),y)
+ifeq ($(BR2_ARM_CPU_ARMV4)$(BR2_ARM_CPU_ARMV5)$(BR2_ARM_CPU_ARMV7M),y)
 NETTLE_CONF_OPTS += --disable-assembler
 endif