toolchain: Allow ld64.so linker
authorJeremy Kerr <jk@ozlabs.org>
Tue, 3 Dec 2013 11:26:13 +0000 (22:26 +1100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 3 Dec 2013 12:11:27 +0000 (13:11 +0100)
The glibc dynamic linkers for ppc64 and s390x are named ld64.so.*
so modify the check_glibc test to match them.

Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Signed-off-by: Anton Blanchard <anton@samba.org>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
toolchain/helpers.mk

index a8944ce0f6d40ffa6ba70dae13017f74ae516c8a..faa9d907451285f2519b6f2b45e89af073be22e5 100644 (file)
@@ -204,7 +204,7 @@ check_glibc_rpc_feature = \
 #
 check_glibc = \
        SYSROOT_DIR="$(strip $1)"; \
-       if test `find $${SYSROOT_DIR}/ -maxdepth 2 -name 'ld-linux*.so.*' -o -name 'ld.so.*' | wc -l` -eq 0 ; then \
+       if test `find $${SYSROOT_DIR}/ -maxdepth 2 -name 'ld-linux*.so.*' -o -name 'ld.so.*' -o -name 'ld64.so.*' | wc -l` -eq 0 ; then \
                echo "Incorrect selection of the C library"; \
                exit -1; \
        fi; \