package/opkg: bumping version to 0.2.0
authorCarsten Schoenert <c.schoenert@gmail.com>
Sat, 5 Oct 2013 18:58:42 +0000 (20:58 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 27 Oct 2013 11:09:30 +0000 (12:09 +0100)
opkg has released a new version v0.2.0. The opkg community is also on
the way to switching completely from subversion to git.
The current git repository is placed on Bitbucket and will probably move
once again if there will be find a new home for the project.
https://bitbucket.org/opkg/opkg

The new version 0.2.0 is almost a bugfixing release with a lot of small
changes.
This patch is adding the license info too.

Signed-off-by: Carsten Schoenert <c.schoenert@gmail.com>
package/opkg/opkg.mk

index f183d6e9ae9381189cbe5e93a140a4165b4ad86b..c57bd7f4640e777ebf41e1e0b8cad5c715b2af98 100644 (file)
@@ -4,14 +4,16 @@
 #
 ################################################################################
 
-OPKG_VERSION = 635
-OPKG_SITE = http://opkg.googlecode.com/svn/trunk/
-OPKG_SITE_METHOD = svn
+OPKG_VERSION = v0.2.0
+OPKG_SOURCE = $(OPKG_VERSION).tar.bz2
+OPKG_SITE = https://bitbucket.org/opkg/opkg/get
+# Uses PKG_CHECK_MODULES() in configure.ac
+OPKG_DEPENDENCIES = host-pkgconf
+OPKG_LICENSE = GPLv2+
+OPKG_LICENSE_FILES = COPYING
 OPKG_INSTALL_STAGING = YES
 OPKG_CONF_OPT = --disable-curl
 OPKG_AUTORECONF = YES
-# Uses PKG_CHECK_MODULES() in configure.ac
-OPKG_DEPENDENCIES = host-pkgconf
 
 # Ensure directory for lockfile exists
 define OPKG_CREATE_LOCKDIR