ntfs-3g: bump to version 2011.4.12 and enhance
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 18 Oct 2011 12:32:10 +0000 (09:32 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 28 Oct 2011 14:11:40 +0000 (16:11 +0200)
ntfsprogs is now included into ntfs-3g so add an option to
enable/disable it.
It probably doesn't make sense to build ntfsprogs alone so it's not
implemented.

Add the encrypted volume support option now that we've got gnutls.

Also add support for libuuid if it's present.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/ntfs-3g/Config.in
package/ntfs-3g/ntfs-3g.mk

index 865f9b41f7955f16933bd0116761a0d60bed81d0..5301038896b1c036bb54ec9656f5cdae4b81c5da 100644 (file)
@@ -12,5 +12,20 @@ config BR2_PACKAGE_NTFS_3G
 
          http://www.ntfs-3g.org/
 
+if BR2_PACKAGE_NTFS_3G
+
+config BR2_PACKAGE_NTFS_3G_ENCRYPTED
+       bool "encrypted volumes"
+       select BR2_PACKAGE_GNUTLS
+       help
+         Enable support for NTFS encrypted volumes.
+
+config BR2_PACKAGE_NTFS_3G_NTFSPROGS
+       bool "ntfsprogs"
+       help
+         Install NTFS utilities.
+
+endif
+
 comment "ntfs-3g requires a toolchain with LARGEFILE and WCHAR support"
        depends on !(BR2_LARGEFILE && BR2_USE_WCHAR)
index 99fc20cb33b0f3190da034a72ce8ca23aecc487a..f6462bb0bbcc539a5a97869faf9a3738d6d36176 100644 (file)
@@ -4,10 +4,29 @@
 #
 #############################################################
 
-NTFS_3G_VERSION = 2010.10.2
-NTFS_3G_SOURCE = ntfs-3g-$(NTFS_3G_VERSION).tgz
+NTFS_3G_VERSION = 2011.4.12
+NTFS_3G_SOURCE = ntfs-3g_ntfsprogs-$(NTFS_3G_VERSION).tgz
 NTFS_3G_SITE = http://tuxera.com/opensource
 NTFS_3G_CONF_OPT = --disable-ldconfig
 NTFS_3G_INSTALL_STAGING = YES
+NTFS_3G_DEPENDENCIES = host-pkg-config
+
+ifeq ($(BR2_PACKAGE_LIBFUSE),y)
+       NTFS_3G_CONF_OPT += --with-fuse=external
+       NTFS_3G_DEPENDENCIES += libfuse
+endif
+
+ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
+       NTFS_3G_DEPENDENCIES += util-linux
+endif
+
+ifeq ($(BR2_PACKAGE_NTFS_3G_ENCRYPTED),y)
+       NTFS_3G_CONF_OPT += --enable-crypto
+       NTFS_3G_DEPENDENCIES += gnutls
+endif
+
+ifneq ($(BR2_PACKAGE_NTFS_3G_NTFSPROGS),y)
+       NTFS_3G_CONF_OPT += --disable-ntfsprogs
+endif
 
 $(eval $(call AUTOTARGETS))