libcurl: bump to version 7.33.0
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 2 Dec 2013 00:27:59 +0000 (21:27 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Dec 2013 07:42:38 +0000 (08:42 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libcurl/libcurl-0001-CVE-2013-4545.patch [deleted file]
package/libcurl/libcurl.mk

diff --git a/package/libcurl/libcurl-0001-CVE-2013-4545.patch b/package/libcurl/libcurl-0001-CVE-2013-4545.patch
deleted file mode 100644 (file)
index 39545fe..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From 3c3622b66221d89509cffaa693fc7dcd5c5b96cf Mon Sep 17 00:00:00 2001
-From: Daniel Stenberg <daniel@haxx.se>
-Date: Wed, 2 Oct 2013 15:31:10 +0200
-Subject: [PATCH] OpenSSL: acknowledge CURLOPT_SSL_VERIFYHOST without
- VERIFYPEER
-
-Setting only CURLOPT_SSL_VERIFYHOST without CURLOPT_SSL_VERIFYPEER set
-should still verify that the host name fields in the server certificate
-is fine or return failure.
-
-Bug: http://curl.haxx.se/mail/lib-2013-10/0002.html
-Reported-by: Ishan SinghLevett
----
- lib/ssluse.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lib/ssluse.c b/lib/ssluse.c
-index 4f3c1e1..9974ac8 100644
---- a/lib/ssluse.c
-+++ b/lib/ssluse.c
-@@ -2351,7 +2351,7 @@ ossl_connect_step3(struct connectdata *conn,
-    * operations.
-    */
--  if(!data->set.ssl.verifypeer)
-+  if(!data->set.ssl.verifypeer && !data->set.ssl.verifyhost)
-     (void)servercert(conn, connssl, FALSE);
-   else
-     retcode = servercert(conn, connssl, TRUE);
--- 
-1.8.3.2
-
index 059f08a1192cdaef766f93fb1bd86f8a83cbe332..afe39d5522226f6a36fdbe6feae8bcb800756993 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBCURL_VERSION = 7.32.0
+LIBCURL_VERSION = 7.33.0
 LIBCURL_SOURCE = curl-$(LIBCURL_VERSION).tar.bz2
 LIBCURL_SITE = http://curl.haxx.se/download
 LIBCURL_DEPENDENCIES = host-pkgconf \