python-keyring: new package
authorLudovic Desroches <ludovic.desroches@atmel.com>
Wed, 11 Dec 2013 20:27:03 +0000 (21:27 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 15 Dec 2013 12:41:33 +0000 (13:41 +0100)
[Thomas: convert to the Python package infrastructure, improved the
.zip handling, added license informations.]

Signed-off-by: Ludovic Desroches <ludovic.desroches@atmel.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/python-keyring/Config.in [new file with mode: 0644]
package/python-keyring/python-keyring.mk [new file with mode: 0644]

index b766939be4117c1b89e032917560abbcdfd3d9d8..e8ecb6acdb0c980726ec0b892ba07779d72d9e0d 100644 (file)
@@ -392,6 +392,7 @@ source "package/python-dialog/Config.in"
 source "package/python-dpkt/Config.in"
 source "package/python-id3/Config.in"
 source "package/python-ipy/Config.in"
+source "package/python-keyring/Config.in"
 source "package/python-mad/Config.in"
 source "package/python-meld3/Config.in"
 source "package/python-msgpack/Config.in"
diff --git a/package/python-keyring/Config.in b/package/python-keyring/Config.in
new file mode 100644 (file)
index 0000000..a6eacf5
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_KEYRING
+       bool "python-keyring"
+       depends on BR2_PACKAGE_PYTHON
+       help
+         The Python keyring lib provides a easy way to access the
+         system keyring service from Python.
+
+         https://pypi.python.org/pypi/keyring
diff --git a/package/python-keyring/python-keyring.mk b/package/python-keyring/python-keyring.mk
new file mode 100644 (file)
index 0000000..3f27f20
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# python-keyring
+#
+################################################################################
+
+PYTHON_KEYRING_VERSION = 3.0.5
+PYTHON_KEYRING_SOURCE = keyring-$(PYTHON_KEYRING_VERSION).zip
+PYTHON_KEYRING_SITE = http://pypi.python.org/packages/source/k/keyring/
+PYTHON_KEYRING_SETUP_TYPE = setuptools
+PYTHON_KEYRING_LICENSE = python software foundation license
+
+define PYTHON_KEYRING_EXTRACT_CMDS
+       unzip -d $(@D) $(DL_DIR)/$(PYTHON_KEYRING_SOURCE)
+       mv $(@D)/keyring-$(PYTHON_KEYRING_VERSION)/* $(@D)
+       $(RM) -r $(@D)/keyring-$(PYTHON_KEYRING_VERSION)
+endef
+
+$(eval $(python-package))