lua-fifo: new package
authorFrancois Perrad <fperrad@gmail.com>
Sun, 24 Sep 2017 16:18:55 +0000 (18:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 3 Oct 2017 20:03:18 +0000 (22:03 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/lua-fifo/Config.in [new file with mode: 0644]
package/lua-fifo/lua-fifo.hash [new file with mode: 0644]
package/lua-fifo/lua-fifo.mk [new file with mode: 0644]

index 23818788e3a7411867a2f6e678ec580b34380b56..c2c0901a4937db24cd385329d90f3f245f950ca6 100644 (file)
@@ -583,6 +583,7 @@ menu "Lua libraries/modules"
        source "package/lua-curl/Config.in"
        source "package/lua-datafile/Config.in"
        source "package/lua-ev/Config.in"
+       source "package/lua-fifo/Config.in"
        source "package/lua-flu/Config.in"
        source "package/lua-iconv/Config.in"
        source "package/lua-markdown/Config.in"
diff --git a/package/lua-fifo/Config.in b/package/lua-fifo/Config.in
new file mode 100644 (file)
index 0000000..5715b6b
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LUA_FIFO
+       bool "lua-fifo"
+       help
+         A lua library/'class' that implements a FIFO.
+
+         https://github.com/daurnimator/fifo.lua
diff --git a/package/lua-fifo/lua-fifo.hash b/package/lua-fifo/lua-fifo.hash
new file mode 100644 (file)
index 0000000..bab3728
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 53dea24ad658614a0254dcb10296a1a0fc5357315ada5724d6362f54c32b4c20  fifo-0.2-0.src.rock
diff --git a/package/lua-fifo/lua-fifo.mk b/package/lua-fifo/lua-fifo.mk
new file mode 100644 (file)
index 0000000..875b895
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# lua-fifo
+#
+################################################################################
+
+LUA_FIFO_VERSION_UPSTREAM =0.2
+LUA_FIFO_VERSION =$(LUA_FIFO_VERSION_UPSTREAM)-0
+LUA_FIFO_NAME_UPSTREAM = fifo
+LUA_FIFO_SUBDIR = fifo.lua-$(LUA_FIFO_VERSION_UPSTREAM)
+LUA_FIFO_LICENSE = MIT
+LUA_FIFO_LICENSE_FILES = $(LUA_FIFO_SUBDIR)/LICENSE
+
+$(eval $(luarocks-package))