luvi: build for the right MIPS endianness
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Mon, 18 Jan 2016 16:09:35 +0000 (16:09 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 19 Jan 2016 21:00:24 +0000 (22:00 +0100)
Otherwise it will cause build failures like this one:

[100%] Linking C executable luvi
/home/buildroot/autobuild/run/instance-2/output/host/opt/ext-toolchain/bin/../lib/gcc/mipsel-buildroot-linux-gnu/5.2.0/../../../../mipsel-buildroot-linux-gnu/bin/ld:
jitted_tmp/src/lua/init.lua_luvi_generated.o: compiled for a big endian
system and target is little endian

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/luvi/luvi.mk

index ef1c2e1d9e583ba4134744de9965d8a840c55a34..d83933e9b315bf473b7dc1a4c970748d1fe4db62 100644 (file)
@@ -20,8 +20,10 @@ else ifeq ($(BR2_powerpc),y)
 LUVI_TARGET_ARCH = ppc
 else ifeq ($(BR2_arm)$(BR2_armeb),y)
 LUVI_TARGET_ARCH = arm
-else ifeq ($(BR2_mips)$(BR2_mipsel),y)
+else ifeq ($(BR2_mips),y)
 LUVI_TARGET_ARCH = mips
+else ifeq ($(BR2_mipsel),y)
+LUVI_TARGET_ARCH = mipsel
 else
 LUVI_TARGET_ARCH = $(BR2_ARCH)
 endif