toolchain: use the <PKG>_TARGET_FINALIZE_HOOKS
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 17 Jul 2016 08:44:24 +0000 (10:44 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 18 Jul 2016 21:30:46 +0000 (23:30 +0200)
Register toolchain-specific target-finalize hooks with the
newly-introduced <PKG>_TARGET_FINALIZE_HOOKS.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain.mk

index 0a359093347fa4727372afb9bc08d2d9474d528a..59fc905caf01acf50db5922ab243f5d74877d3e1 100644 (file)
@@ -10,7 +10,7 @@ define GLIBC_COPY_NSSWITCH_FILE
                $(INSTALL) -D -m 0644 package/glibc/nsswitch.conf $(TARGET_DIR)/etc/nsswitch.conf ; \
        fi
 endef
-TARGET_FINALIZE_HOOKS += GLIBC_COPY_NSSWITCH_FILE
+TOOLCHAIN_TARGET_FINALIZE_HOOKS += GLIBC_COPY_NSSWITCH_FILE
 endif
 
 # Install the gconv modules
@@ -52,5 +52,5 @@ define COPY_GCONV_LIBS
                        >$(TARGET_DIR)/usr/lib/gconv/gconv-modules; \
        fi
 endef
-TARGET_FINALIZE_HOOKS += COPY_GCONV_LIBS
+TOOLCHAIN_TARGET_FINALIZE_HOOKS += COPY_GCONV_LIBS
 endif