- fix setting the REAL_GCC_VERSION if no snapdate was given (i.e. we're using a svn...
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 22 Dec 2006 11:38:07 +0000 (11:38 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 22 Dec 2006 11:38:07 +0000 (11:38 -0000)
  sjhill, please verify that this still works for you!

toolchain/gcc/gcc-uclibc-3.x.mk

index 00471d71e62b59139bc2f7ebb6305a730bf80530..0b63bb3425ff87447260055884221561f3e058cb 100644 (file)
@@ -336,8 +336,8 @@ ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
 GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
 endif
 ifeq ($(findstring 4.2,$(GCC_VERSION)),4.2)
-ifneq ($(GCC_SNAP_DATE),)
-REAL_GCC_VERSION:=`cat ${GCC_DIR}/gcc/BASE-VER`
+ifneq ($(findstring 4.2.,$(GCC_VERSION)),4.2.)
+REAL_GCC_VERSION=$(shell cat $(GCC_DIR)/gcc/BASE-VER)
 GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(REAL_GCC_VERSION)
 else
 GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)