package/runc: use BR_PATH to find pkg-config
authorRomain Naour <romain.naour@gmail.com>
Thu, 7 Jul 2016 18:39:35 +0000 (20:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 8 Jul 2016 19:03:52 +0000 (21:03 +0200)
When BR2_PACKAGE_LIBSECCOMP is set, go will try to find libseccomp
library using pkg-config. But pkg-config is not in the PATH when go
is called during the runc build.

Set the correct PATH in RUNC_MAKE_ENV.

Fixes:
http://autobuild.buildroot.net/results/fea/fea069fec671b32bffd3d133898d71d45abab552

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Christian Stewart <christian@paral.in>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/runc/runc.mk

index c4e75dd0a289ac3a730e23f050065f7562baa9c6..1396e0c7a2834ef3905499a9458b7a9c43e4e446 100644 (file)
@@ -15,7 +15,8 @@ RUNC_GOPATH = "$(@D)/Godeps/_workspace"
 RUNC_MAKE_ENV = $(HOST_GO_TARGET_ENV) \
        CGO_ENABLED=1 \
        GOBIN="$(@D)/bin" \
-       GOPATH="$(RUNC_GOPATH)"
+       GOPATH="$(RUNC_GOPATH)" \
+       PATH=$(BR_PATH)
 
 RUNC_GLDFLAGS = \
        -X main.gitCommit=$(RUNC_VERSION) \