if target arch installs into a lib64 dir, make sure we move the stuff to plain old lib
authorMike Frysinger <vapier@gentoo.org>
Thu, 22 Sep 2005 03:06:33 +0000 (03:06 -0000)
committerMike Frysinger <vapier@gentoo.org>
Thu, 22 Sep 2005 03:06:33 +0000 (03:06 -0000)
toolchain/gcc/gcc-uclibc-3.x.mk

index ff08458c5bfff5ade1b44dc20bb8a734ed5f30c9..455b7d30c653e78e5ed2d5cee17426f2bd54050e 100644 (file)
@@ -176,6 +176,13 @@ $(GCC_BUILD_DIR2)/.compiled: $(GCC_BUILD_DIR2)/.configured
 
 $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
        PATH=$(TARGET_PATH) $(MAKE) -C $(GCC_BUILD_DIR2) install
+       if [ -d "$(STAGING_DIR)/lib64" ] ; then \
+               if [ ! -e "$(STAGING_DIR)/lib" ] ; then \
+                       mkdir "$(STAGING_DIR)/lib" ; \
+               fi ; \
+               mv "$(STAGING_DIR)/lib64/"* "$(STAGING_DIR)/lib/" ; \
+               rmdir "$(STAGING_DIR)/lib64" ; \
+       fi
        # Strip the host binaries
 ifeq ($(GCC_STRIP_HOST_BINARIES),true)
        -strip --strip-all -R .note -R .comment $(STAGING_DIR)/bin/*