projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
88b6382
)
systemd: fix sed line in "sanitize path in units" hook
author
Ivan Sergeev
<vsergeev@kumunetworks.com>
Sat, 15 Feb 2014 02:42:57 +0000
(18:42 -0800)
committer
Peter Korsgaard
<peter@korsgaard.com>
Sat, 15 Feb 2014 07:21:50 +0000
(08:21 +0100)
The expanded SED variable already contains -e, so the extra -e was being
interpreted as the sed command and causing sed to fail.
Signed-off-by: Ivan Sergeev <vsergeev@kumunetworks.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/systemd/systemd.mk
patch
|
blob
|
history
diff --git
a/package/systemd/systemd.mk
b/package/systemd/systemd.mk
index 90860456da2947c817a86b2e628614ede84e321f..36ef704c7bcee19ebdb87b9ac2b41b07b2f92d5f 100644
(file)
--- a/
package/systemd/systemd.mk
+++ b/
package/systemd/systemd.mk
@@
-103,7
+103,7
@@
endef
define SYSTEMD_SANITIZE_PATH_IN_UNITS
find $(TARGET_DIR)/lib/systemd/system -name '*.service' \
- -exec $(SED)
-e
's,$(HOST_DIR),,g' {} \;
+ -exec $(SED) 's,$(HOST_DIR),,g' {} \;
endef
SYSTEMD_POST_INSTALL_TARGET_HOOKS += \