ruby: fix build breakage
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 25 Nov 2011 11:35:11 +0000 (08:35 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 26 Nov 2011 13:30:11 +0000 (14:30 +0100)
Fix build breakage regarding invalid file format of
/usr/lib/libpthread.so
This is because ruby has rpath enabled by default and was throwing in
the runtime paths and pulling in host libraries into the mix.
So disable rpath.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/ruby/ruby.mk

index 34953336fd610f29ce68a51b75573110b3507c3f..a34a2512abbe164daf478a30c45b31eb5836f85f 100644 (file)
@@ -10,7 +10,7 @@ RUBY_AUTORECONF = YES
 HOST_RUBY_AUTORECONF = YES
 RUBY_DEPENDENCIES = host-ruby
 RUBY_MAKE_ENV = $(TARGET_MAKE_ENV)
-RUBY_CONF_OPT = --disable-install-doc
+RUBY_CONF_OPT = --disable-install-doc --disable-rpath
 
 HOST_RUBY_CONF_OPT = --disable-install-doc