grub2: fix build with BR2_STRIP_none
authorCharles Hardin <ckhardin@exablox.com>
Sat, 21 May 2016 20:11:09 +0000 (13:11 -0700)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 31 Jul 2016 18:19:40 +0000 (20:19 +0200)
grub2 assumes the strip command will generate output and the output should
always be stripped - so, just use the $(TARGET_CROSS)strip to make sure that
the build succeeds regardless of the buildroot strip configuration.

Signed-off-by: Charles Hardin <ckhardin@exablox.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
boot/grub2/grub2.mk

index 112a401b02e888f6f645ae0710c243c3e531e77c..dc4e51ea8e24e6da9259e88cc65f7587f5f66fde 100644 (file)
@@ -45,6 +45,9 @@ endif
 # the confusion, it also uses NM, OBJCOPY and STRIP to build the
 # bootloader itself; none of these are used to build the native
 # tools.
+#
+# NOTE: TARGET_STRIP is overridden by BR2_STRIP_none, so always
+# use the cross compile variant to ensure grub2 builds
 
 GRUB2_CONF_ENV = \
        $(HOST_CONFIGURE_OPTS) \
@@ -55,7 +58,7 @@ GRUB2_CONF_ENV = \
        TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
        NM="$(TARGET_NM)" \
        OBJCOPY="$(TARGET_OBJCOPY)" \
-       STRIP="$(TARGET_STRIP)"
+       STRIP="$(TARGET_CROSS)strip"
 
 GRUB2_CONF_OPTS = \
        --target=$(GRUB2_TARGET) \