Makefile: Ensure CVS directories are removed from target fs.
authorWill Newton <will.newton@gmail.com>
Mon, 10 Aug 2009 09:04:14 +0000 (10:04 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 26 Aug 2009 21:00:38 +0000 (23:00 +0200)
The find command syntax is incorrect when deleting CVS and .svn directories
from the target filesystem, which prevent CVS directories from being
deleted.

It's useful to delete these dirs because users of buildroot often import
buildroot into CVS or Subversion.

Signed-off-by: Will Newton <will.newton@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 182853ce9cad0277cf6d5c76afeb2444a5c0a07b..56834849448b5bc37954bdc3737e2acd922474b4 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -337,7 +337,7 @@ $(PROJECT_BUILD_DIR)/.root:
                fi; \
                touch $(STAGING_DIR)/.fakeroot.00000; \
        fi
-       -find $(TARGET_DIR) -type d -name CVS -o -name .svn -print0 | xargs -0 rm -rf
+       -find $(TARGET_DIR) -type d -name CVS -print0 -o -name .svn -print0 | xargs -0 rm -rf
        -find $(TARGET_DIR) -type f -name .empty -print0 | xargs -0 rm -rf
        touch $@