gstreamer: Added option to disable plugin registry.
authorTim Sheridan <Tim.Sheridan@imgtec.com>
Mon, 26 Nov 2012 01:26:04 +0000 (01:26 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 30 Nov 2012 08:01:17 +0000 (00:01 -0800)
The plugin registry can take a while to be generated when GStreamer is
initialized. Turning it off can speed up up GStreamer application launch
times. Default behaviour is unchanged.

Signed-off-by: Tim Sheridan <tim.sheridan@imgtec.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gstreamer/Config.in
package/multimedia/gstreamer/gstreamer.mk

index 4d279b8b1c105ded2828e229d7bc6366a5855fc7..9a6748106bfb8ad8e8875b6d19be1d33ebe8f671 100644 (file)
@@ -12,9 +12,17 @@ config BR2_PACKAGE_GSTREAMER_GST_DEBUG
        default y
        depends on BR2_PACKAGE_GSTREAMER
        help
-         Enable support for the gst-debug tracing functionality
-         in gstreamer. This has limited CPU overhead, but does
-         increase the rootfs size somewhat.
+         Enable support for the gst-debug tracing functionality in gstreamer.
+         This has limited CPU overhead, but does increase the rootfs size
+         somewhat.
+
+config BR2_PACKAGE_GSTREAMER_PLUGIN_REGISTRY
+       bool "enable plugin registry"
+       default y
+       depends on BR2_PACKAGE_GSTREAMER
+       help
+         Enable support for the GStreamer plugin registry. This may increase
+         the launch-time for a GStreamer application.
 
 comment "gstreamer requires a toolchain with WCHAR support"
        depends on !BR2_USE_WCHAR
index a9841b17c0bea587fada168204857ac33d2f4b47..b87f0294ffc528d925ae9982e8aa3a27866e2db4 100644 (file)
@@ -21,7 +21,8 @@ GSTREAMER_CONF_OPT = \
                --disable-tests \
                --disable-failing-tests \
                --disable-loadsave \
-               $(if $(BR2_PACKAGE_GSTREAMER_GST_DEBUG),,--disable-gst-debug)
+               $(if $(BR2_PACKAGE_GSTREAMER_GST_DEBUG),,--disable-gst-debug) \
+               $(if $(BR2_PACKAGE_GSTREAMER_PLUGIN_REGISTRY),,--disable-registry)
 
 GSTREAMER_DEPENDENCIES = libglib2 host-pkgconf