dosfstools: fix host variant dependencies
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 21 Mar 2013 02:12:34 +0000 (02:12 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Mar 2013 10:54:13 +0000 (11:54 +0100)
host-dosfstools shouldn't pull host-libiconv in since that's for
uClibc-based toolchains and we don't have that package anyway.
Fixes:
http://autobuild.buildroot.net/results/7637985bfb0afdd9217c297e9b0ac5de797c137d/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/dosfstools/dosfstools.mk

index 332f2eef355063a7ee56e4601136ffd7242f6539..79d1c7acf139fd789705b76bfa7cbc0f60f7831d 100644 (file)
@@ -10,6 +10,9 @@ DOSFSTOOLS_LICENSE = GPLv3+
 DOSFSTOOLS_LICENSE_FILES = COPYING
 DOSFSTOOLS_LDFLAGS = $(TARGET_LDFLAGS)
 
+# Avoid target dosfstools dependencies, no host-libiconv
+HOST_DOSFSTOOLS_DEPENDENCIES =
+
 ifneq ($(BR2_ENABLE_LOCALE),y)
 DOSFSTOOLS_DEPENDENCIES += libiconv
 DOSFSTOOLS_LDFLAGS += -liconv