orc: target install: cleanup unused files
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 4 Aug 2011 19:15:40 +0000 (21:15 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 4 Aug 2011 19:15:40 +0000 (21:15 +0200)
orcc is only needed when developing.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/orc/orc.mk

index f89d5cf93e2782b831455e53b027eb0e5494e683..37b6e991cfad7a0d8e58faa63b0624f109729321 100644 (file)
@@ -7,4 +7,18 @@ ORC_VERSION = 0.4.14
 ORC_SITE = http://code.entropywave.com/download/orc/
 ORC_INSTALL_STAGING = YES
 
+define ORC_REMOVE_BUGREPORT
+       rm -f $(TARGET_DIR)/usr/bin/orc-bugreport
+endef
+
+define ORC_REMOVE_DEVFILES
+       rm -f $(TARGET_DIR)/usr/bin/orcc
+endef
+
+ORC_POST_INSTALL_TARGET_HOOKS += ORC_REMOVE_BUGREPORT
+
+ifneq ($(BR2_HAVE_DEVFILES),y)
+ORC_POST_INSTALL_TARGET_HOOKS += ORC_REMOVE_DEVFILES
+endif
+
 $(eval $(call AUTOTARGETS,package,orc))