binutils: disable warning flags to prevent build failures
authorVlad Zakharov <vzakhar@synopsys.com>
Fri, 19 Aug 2016 16:29:21 +0000 (19:29 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 19 Aug 2016 21:05:45 +0000 (23:05 +0200)
binutils-arc-2016.09-eng008 build fails sometimes.

This happens due to the following issue:

binutils configure script has CC variable that stores compiler for
target and CC_FOR_BUILD variable that stores compiler for host.

WARN_FLAGS are verified by the script to be compatible only with CC
compiler but not with CC_FOR_BUILD compiler. Despite this WARN_FLAGS
are passed to both CC and CC_FOR_BUILD compilers. This leads to
unevident errors when cross-compiling. More information you can find
in the binutils mailing list:
https://sourceware.org/ml/binutils/2016-08/msg00117.html

We are going to write a patch for bunutils that fixes the initial
issue. Current patch contains temporary workaround. It should be
deleted after real fix.

Fixes:
http://autobuild.buildroot.net/results/00455b6a8324920ad843d90ce0413451522691a8//

Signed-off-by: Vlad Zakharov <vzakhar@synopsys.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/binutils/binutils.mk

index aeabf75b3fc16866dcd4d899e01a6f43a35152c3..2936eb518a5c8129143af428e49d004ee5a10488 100644 (file)
@@ -58,6 +58,7 @@ BINUTILS_CONF_OPTS = \
        --host=$(GNU_TARGET_NAME) \
        --target=$(GNU_TARGET_NAME) \
        --enable-install-libiberty \
+       --enable-build-warnings=no \
        $(BINUTILS_DISABLE_GDB_CONF_OPTS) \
        $(BINUTILS_EXTRA_CONFIG_OPTIONS)