package/gnu-efi: bump to version 3.0.10
authorJames Hilliard <james.hilliard1@gmail.com>
Mon, 14 Oct 2019 16:52:27 +0000 (10:52 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 16 Oct 2019 20:00:23 +0000 (22:00 +0200)
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gnu-efi/0001-Fix-for-problem-with-undeclared-intptr_t-type.patch [deleted file]
package/gnu-efi/0001-Make.defaults-don-t-override-ARCH-when-cross-compili.patch [new file with mode: 0644]
package/gnu-efi/0002-Make.defaults-don-t-override-ARCH-when-cross-compili.patch [deleted file]
package/gnu-efi/gnu-efi.hash
package/gnu-efi/gnu-efi.mk

diff --git a/package/gnu-efi/0001-Fix-for-problem-with-undeclared-intptr_t-type.patch b/package/gnu-efi/0001-Fix-for-problem-with-undeclared-intptr_t-type.patch
deleted file mode 100644 (file)
index 1d1b1f9..0000000
+++ /dev/null
@@ -1,114 +0,0 @@
-From 1a53d8f88a452847b25f9689f9a08dbcf82c86e4 Mon Sep 17 00:00:00 2001
-From: Esben Haabendal <esben@esben1.localdomain>
-Date: Fri, 15 Mar 2019 11:57:51 +0100
-Subject: [PATCH] Fix for problem with undeclared intptr_t type
-
-When building gnu-efi with old compilers with pre C90 compilers:
-
-In file included from gnu-efi-3.0.9/lib/../inc/efilib.h:25:0,
-                 from gnu-efi-3.0.9/lib/lib.h:24,
-                 from gnu-efi-3.0.9/lib/dpath.c:25:
-gnu-efi-3.0.9/lib/dpath.c: In function 'FileDevicePath':
-gnu-efi-3.0.9/lib/../inc/efilink.h:145:47: error: 'intptr_t' undeclared (first use in this function)
- #define EFI_FIELD_OFFSET(TYPE,Field) ((UINTN)(intptr_t)(&(((TYPE *) 0)->Field)))
-
-Problem introduced with commit a46a62b12b58139c31d4288384808365c4053bf2
-(Fix some types gcc doesn't like).
-
-Avoid this by adding intptr_t (and uintptr_t) typedefs for builds that does
-not include stdint.h.
-
-Signed-off-by: Esben Haabendal <esben@esben1.localdomain>
-Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
-[Upstream status:
-https://sourceforge.net/p/gnu-efi/code/merge-requests/5]
----
- inc/aarch64/efibind.h  | 2 ++
- inc/arm/efibind.h      | 2 ++
- inc/ia32/efibind.h     | 2 ++
- inc/ia64/efibind.h     | 2 ++
- inc/mips64el/efibind.h | 2 ++
- inc/x86_64/efibind.h   | 2 ++
- 6 files changed, 12 insertions(+)
-
-diff --git a/inc/aarch64/efibind.h b/inc/aarch64/efibind.h
-index bdaa523..3c8cf96 100644
---- a/inc/aarch64/efibind.h
-+++ b/inc/aarch64/efibind.h
-@@ -27,6 +27,8 @@ typedef unsigned short      uint16_t;
- typedef short               int16_t;
- typedef unsigned char       uint8_t;
- typedef signed char         int8_t;   // unqualified 'char' is unsigned on ARM
-+typedef uint64_t            uintptr_t;
-+typedef int64_t             intptr_t;
- #else
- #include <stdint.h>
-diff --git a/inc/arm/efibind.h b/inc/arm/efibind.h
-index 40a5a9c..7a22b9c 100644
---- a/inc/arm/efibind.h
-+++ b/inc/arm/efibind.h
-@@ -27,6 +27,8 @@ typedef unsigned short      uint16_t;
- typedef short               int16_t;
- typedef unsigned char       uint8_t;
- typedef signed char         int8_t;   // unqualified 'char' is unsigned on ARM
-+typedef uint32_t            uintptr_t;
-+typedef int32_t             intptr_t;
- #else
- #include <stdint.h>
-diff --git a/inc/ia32/efibind.h b/inc/ia32/efibind.h
-index 1b11f10..dd01385 100644
---- a/inc/ia32/efibind.h
-+++ b/inc/ia32/efibind.h
-@@ -75,6 +75,8 @@ Revision History
-        typedef unsigned char       uint8_t;
-        typedef char                int8_t;
-     #endif
-+    typedef uint32_t            uintptr_t;
-+    typedef int32_t             intptr_t;
- #elif defined(__GNUC__)
-     #include <stdint.h>
- #endif
-diff --git a/inc/ia64/efibind.h b/inc/ia64/efibind.h
-index b415461..b9b2e62 100644
---- a/inc/ia64/efibind.h
-+++ b/inc/ia64/efibind.h
-@@ -62,6 +62,8 @@ Revision History
-         typedef unsigned char       uint8_t;
-         typedef char                int8_t;
-     #endif
-+    typedef uint64_t            uintptr_t;
-+    typedef int64_t             intptr_t;
- #elif defined(__GNUC__)
-     #include <stdint.h>
- #endif
-diff --git a/inc/mips64el/efibind.h b/inc/mips64el/efibind.h
-index 4adbca3..32241e5 100644
---- a/inc/mips64el/efibind.h
-+++ b/inc/mips64el/efibind.h
-@@ -29,6 +29,8 @@ typedef unsigned short      uint16_t;
- typedef short               int16_t;
- typedef unsigned char       uint8_t;
- typedef signed char         int8_t;   // unqualified 'char' is unsigned on ARM
-+typedef uint64_t            uintptr_t;
-+typedef int64_t             intptr_t;
- #else
- #include <stdint.h>
-diff --git a/inc/x86_64/efibind.h b/inc/x86_64/efibind.h
-index 4309f9f..ae40595 100644
---- a/inc/x86_64/efibind.h
-+++ b/inc/x86_64/efibind.h
-@@ -84,6 +84,8 @@ Revision History
-        typedef unsigned char       uint8_t;
-        typedef char                int8_t;
-     #endif
-+    typedef uint64_t            uintptr_t;
-+    typedef int64_t             intptr_t;
- #elif defined(__GNUC__)
-     #include <stdint.h>
- #endif
--- 
-2.17.1
-
diff --git a/package/gnu-efi/0001-Make.defaults-don-t-override-ARCH-when-cross-compili.patch b/package/gnu-efi/0001-Make.defaults-don-t-override-ARCH-when-cross-compili.patch
new file mode 100644 (file)
index 0000000..c256541
--- /dev/null
@@ -0,0 +1,32 @@
+From 3452721eafae90749f4af63264c412f398460b15 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Sun, 20 Jan 2019 21:07:11 +0100
+Subject: [PATCH] Make.defaults: don't override ARCH when cross-compiling
+
+Don't override the user-provided ARCH when cross-compiling otherwise
+ARCH won't be correct for armv5, aarch64 and x86_64
+
+Fixes:
+ - http://autobuild.buildroot.org/results/2dfc0e10da25a8382a43557420d7dc3444c02dbb
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ Make.defaults | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Make.defaults b/Make.defaults
+index ba743f1..a0e5632 100755
+--- a/Make.defaults
++++ b/Make.defaults
+@@ -67,7 +67,7 @@ ARCH         ?= $(shell $(HOSTCC) -dumpmachine | cut -f1 -d- | sed -e s,i[345678
+ # Get ARCH from the compiler if cross compiling 
+ ifneq ($(CROSS_COMPILE),)
+-  override ARCH := $(shell $(CC) -dumpmachine | cut -f1 -d-| sed -e s,i[3456789]86,ia32, -e 's,armv7.*,arm,' )
++  ARCH := $(shell $(CC) -dumpmachine | cut -f1 -d-| sed -e s,i[3456789]86,ia32, -e 's,armv7.*,arm,' )
+ endif
+ # FreeBSD (and possibly others) reports amd64 instead of x86_64
+-- 
+2.14.1
+
diff --git a/package/gnu-efi/0002-Make.defaults-don-t-override-ARCH-when-cross-compili.patch b/package/gnu-efi/0002-Make.defaults-don-t-override-ARCH-when-cross-compili.patch
deleted file mode 100644 (file)
index c256541..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From 3452721eafae90749f4af63264c412f398460b15 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Sun, 20 Jan 2019 21:07:11 +0100
-Subject: [PATCH] Make.defaults: don't override ARCH when cross-compiling
-
-Don't override the user-provided ARCH when cross-compiling otherwise
-ARCH won't be correct for armv5, aarch64 and x86_64
-
-Fixes:
- - http://autobuild.buildroot.org/results/2dfc0e10da25a8382a43557420d7dc3444c02dbb
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- Make.defaults | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Make.defaults b/Make.defaults
-index ba743f1..a0e5632 100755
---- a/Make.defaults
-+++ b/Make.defaults
-@@ -67,7 +67,7 @@ ARCH         ?= $(shell $(HOSTCC) -dumpmachine | cut -f1 -d- | sed -e s,i[345678
- # Get ARCH from the compiler if cross compiling 
- ifneq ($(CROSS_COMPILE),)
--  override ARCH := $(shell $(CC) -dumpmachine | cut -f1 -d-| sed -e s,i[3456789]86,ia32, -e 's,armv7.*,arm,' )
-+  ARCH := $(shell $(CC) -dumpmachine | cut -f1 -d-| sed -e s,i[3456789]86,ia32, -e 's,armv7.*,arm,' )
- endif
- # FreeBSD (and possibly others) reports amd64 instead of x86_64
--- 
-2.14.1
-
index 9ac2b51fe3653f93701518f36fc5d05f75acd621..bf9792b290e4e4d1e02b68df6e88329cb06602de 100644 (file)
@@ -1,6 +1,6 @@
 # From http://sourceforge.net/projects/gnu-efi/files
-md5 32af17b917545a693e549af2439c4a99 gnu-efi-3.0.9.tar.bz2
-sha1 9b39e06206e63eba56d59a648a7e4f20aead6962 gnu-efi-3.0.9.tar.bz2
+md5 960a8379b6f95ee73d7778b70bf2a089 gnu-efi-3.0.10.tar.bz2
+sha1 a51b81eda97c0acbf3ac86123f298d3c0e396ce5 gnu-efi-3.0.10.tar.bz2
 # Locally computed
-sha256 6715ea7eae1c7e4fc5041034bd3f107ec2911962ed284a081e491646b12277f0  gnu-efi-3.0.9.tar.bz2
+sha256 f12082a3a5f0c3e38c67262a9f34245d139ac2cdfc0a0bdcf03c9b1f56fa4fed  gnu-efi-3.0.10.tar.bz2
 sha256 42d352e9c28dd446fd0209cd6f75588c8e41f0934540bb382bbd61c752360265  README.efilib
index fe3c8ac343ef72f95fdc3b25dc5028e93ba41c1c..69618029f48ebbfc40d00eaf973e81069a3983ae 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-GNU_EFI_VERSION = 3.0.9
+GNU_EFI_VERSION = 3.0.10
 GNU_EFI_SOURCE = gnu-efi-$(GNU_EFI_VERSION).tar.bz2
 GNU_EFI_SITE = http://downloads.sourceforge.net/project/gnu-efi
 GNU_EFI_INSTALL_STAGING = YES