libedit: fix build error with musl toolchain
authorSergio Prado <sergio.prado@e-labworks.com>
Thu, 7 Jan 2016 00:41:17 +0000 (22:41 -0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 18 Jan 2016 22:01:03 +0000 (23:01 +0100)
Libedit build fails when __STDC_ISO_10646__ is not defined, and that is
the case when compiling with musl toolchains.

chartype.h:52:3: error: #error wchar_t must store ISO 10646 characters
  #error wchar_t must store ISO 10646 characters
   ^

Musl is ISO 10646 compliant but doesn't define __STDC_ISO_10646__, so
let's define it manually.

Fixes:
http://autobuild.buildroot.net/results/3d12a7e6423d236c9d528bca7cbcf86b1499d738/
http://autobuild.buildroot.net/results/b92f7e2b86ffa575d8a8a0b91fbdd9bcb0f231de/
http://autobuild.buildroot.net/results/c476a48936f8810117bb292fb0d8a43c09068de6/
http://autobuild.buildroot.net/results/a30bb1423cc92137a2deaec0a32c7df947384d49/

Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com>
Tested-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libedit/libedit.mk

index 87a1cdc136d62108ee6dc1bb17094211058a147a..e7ddd1fcb56238fbcb498328cb8ec52dd4fd9a28 100644 (file)
@@ -23,6 +23,12 @@ LIBEDIT_POST_EXTRACT_HOOKS += LIBEDIT_FIXUP_M4_DIR
 # Doesn't really support !wchar, but support is disabled otherwise
 LIBEDIT_CONF_OPTS += --enable-widec
 
+# musl is ISO 10646 compliant but doesn't define __STDC_ISO_10646__,
+# so let's define it manually
+ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
+LIBEDIT_CONF_OPTS += CFLAGS="$(TARGET_CFLAGS) -D__STDC_ISO_10646__=201103L"
+endif
+
 # Note: libbsd required for *vis functions, but works only with a toolchain
 # with __progname; otherwise, some features are disabled, as if libbsd was
 # missing entirely.