keepalived: add libglib2 optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 19 Nov 2018 18:06:50 +0000 (19:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 19 Nov 2018 20:42:43 +0000 (21:42 +0100)
gio from libglib2 is used for dbus support

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/keepalived/keepalived.mk

index fa8b2e41120370c6b7c493b02d306579a9b6f1f7..ed80a79f8aac8c3b4d2a642718082fe9f419ff25 100644 (file)
@@ -11,7 +11,6 @@ KEEPALIVED_LICENSE = GPL-2.0+
 KEEPALIVED_LICENSE_FILES = COPYING
 # 0001-configure.ac-do-not-force-PIE.patch
 KEEPALIVED_AUTORECONF = YES
-KEEPALIVED_CONF_OPTS += --disable-dbus
 
 ifeq ($(BR2_PACKAGE_JSON_C),y)
 KEEPALIVED_DEPENDENCIES += json-c
@@ -20,6 +19,13 @@ else
 KEEPALIVED_CONF_OPTS += --disable-json
 endif
 
+ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
+KEEPALIVED_DEPENDENCIES += libglib2
+KEEPALIVED_CONF_OPTS += --enable-dbus
+else
+KEEPALIVED_CONF_OPTS += --disable-dbus
+endif
+
 ifeq ($(BR2_PACKAGE_LIBNL)$(BR2_PACKAGE_LIBNFNETLINK),yy)
 KEEPALIVED_DEPENDENCIES += libnl libnfnetlink
 KEEPALIVED_CONF_OPTS += --enable-libnl