package/efl: add poppler imageloader optional dependency
authorRomain Naour <romain.naour@gmail.com>
Fri, 14 Apr 2017 21:14:24 +0000 (23:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 15 Apr 2017 08:43:20 +0000 (10:43 +0200)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/efl.mk

index c71c084985f370a2fcf3d4df6a1b17361dc3f13d..4008d30a86041e5a756875226a7b89649062b9b0 100644 (file)
@@ -24,7 +24,6 @@ EFL_DEPENDENCIES = host-pkgconf host-efl host-luajit dbus freetype \
 
 # Configure options:
 # --disable-lua-old: build elua for the target.
-# --disable-poppler: disable poppler image loader.
 # --disable-sdl: disable sdl2 support.
 # --disable-spectre: disable spectre image loader.
 # --disable-xinput22: disable X11 XInput v2.2+ support.
@@ -43,7 +42,6 @@ EFL_CONF_OPTS = \
        --disable-image-loader-jp2k \
        --with-net-control=none \
        --disable-lua-old \
-       --disable-poppler \
        --disable-sdl \
        --disable-spectre \
        --disable-xinput22 \
@@ -262,6 +260,13 @@ else
 EFL_CONF_OPTS += --disable-image-loader-webp
 endif
 
+ifeq ($(BR2_PACKAGE_POPPLER),y)
+EFL_DEPENDENCIES += poppler
+EFL_CONF_OPTS += --enable-poppler
+else
+EFL_CONF_OPTS += --disable-poppler
+endif
+
 ifeq ($(BR2_PACKAGE_EFL_LIBRAW),y)
 EFL_DEPENDENCIES += libraw
 EFL_CONF_OPTS += --enable-libraw