package/parprouted: new package
authorOwen Walpole <owen@walpole.dev>
Thu, 2 Jul 2020 03:53:27 +0000 (22:53 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Jul 2020 21:47:06 +0000 (23:47 +0200)
parprouted is a daemon for transparent IP (Layer 3) proxy ARP
bridging. This is useful for creation of transparent firewalls
and bridging networks with different MAC protocols. Also,
unlike standard bridging, proxy ARP bridging allows to bridge
Ethernet networks behind wireless nodes without using WDS or
layer 2 bridging.

https://www.hazard.maks.net/parprouted

Signed-off-by: Owen Walpole <owen@walpole.dev>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/parprouted/Config.in [new file with mode: 0644]
package/parprouted/parprouted.hash [new file with mode: 0644]
package/parprouted/parprouted.mk [new file with mode: 0644]

index 0723fe24f046e9ec14f77ff2bfed4366de7383d9..efbb676b48866fee8a9ddd4cdae0d3bba622e6b6 100644 (file)
@@ -1932,6 +1932,9 @@ F:        package/openjpeg/
 N:     Olivier Singla <olivier.singla@gmail.com>
 F:     package/shellinabox/
 
+N:     Owen Walpole <owen@walpole.dev>
+F:     package/parprouted/
+
 N:     Parnell Springmeyer <parnell@digitalmentat.com>
 F:     package/scrypt/
 
index 1cab73d122f19a4d234c1818e9aefd88196593a0..aafaa312a10c1871f18d31e2977da08798edba82 100644 (file)
@@ -2155,6 +2155,7 @@ endif
        source "package/openswan/Config.in"
        source "package/openvpn/Config.in"
        source "package/p910nd/Config.in"
+       source "package/parprouted/Config.in"
        source "package/phidgetwebservice/Config.in"
        source "package/phytool/Config.in"
        source "package/pimd/Config.in"
diff --git a/package/parprouted/Config.in b/package/parprouted/Config.in
new file mode 100644 (file)
index 0000000..7cf839d
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_PARPROUTED
+       bool "parprouted"
+       depends on BR2_USE_MMU # fork()
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       help
+         parprouted is a daemon for transparent IP (Layer 3) proxy ARP
+         bridging. This is useful for creation of transparent firewalls
+         and bridging networks with different MAC protocols. Also,
+         unlike standard bridging, proxy ARP bridging allows to bridge
+         Ethernet networks behind wireless nodes without using WDS or
+         layer 2 bridging.
+
+         https://www.hazard.maks.net/parprouted
+
+comment "parprouted needs a toolchain w/ threads"
+       depends on BR2_USE_MMU
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/parprouted/parprouted.hash b/package/parprouted/parprouted.hash
new file mode 100644 (file)
index 0000000..ec73f92
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed
+sha256  4b8cb2c801047f26b63aefaa8d69adc8552fb7c8a8f5d851798a48f841948d36  parprouted-0.65.tar.gz
+sha256  dcc100d4161cc0b7177545ab6e47216f84857cda3843847c792a25289852dcaa  COPYING
diff --git a/package/parprouted/parprouted.mk b/package/parprouted/parprouted.mk
new file mode 100644 (file)
index 0000000..0956578
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# parprouted
+#
+################################################################################
+
+PARPROUTED_VERSION = 0.65
+PARPROUTED_SITE = https://www.hazard.maks.net/parprouted
+PARPROUTED_LICENSE = GPL-2.0
+PARPROUTED_LICENSE_FILES = COPYING
+
+define PARPROUTED_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) all
+endef
+
+define PARPROUTED_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/parprouted $(TARGET_DIR)/usr/sbin/parprouted
+endef
+
+$(eval $(generic-package))