c-icap: avoid host library search path
authorBaruch Siach <baruch@tkos.co.il>
Tue, 26 Apr 2016 07:36:55 +0000 (10:36 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 26 Apr 2016 20:01:09 +0000 (22:01 +0200)
Add AUTORECONF as a workaround to the effect of '-Wl,-rpath -Wl,/usr/lib' that
c-icap adds to the linker command.

Fixes:
http://autobuild.buildroot.net/results/077/077374329b2782dbb4b4a9ee7af264cdda311ccc/
http://autobuild.buildroot.net/results/057/057a88179150a4f02990d7b9b0d8f2de3c9da1a3/
http://autobuild.buildroot.net/results/da6/da62b80989df6b8f1b5557b4987d7a6999d30bb8/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/c-icap/c-icap.mk

index cff642cd9cc1ad5de9e404593ab039d751526c00..3078721bce53b8f6a02334758fcb69ccda0e2ded 100644 (file)
@@ -20,6 +20,13 @@ C_ICAP_CONF_OPTS = \
 # Pre-seed cache variables for tests done with AC_TRY_RUN that are not
 # cross-compile friendly
 C_ICAP_CONF_ENV = ac_cv_10031b_ipc_sem=yes ac_cv_fcntl=yes
+# c-icap adds '-Wl,-rpath -Wl,/usr/lib' to the link command line. This
+# causes the linker to search for libraries that are listed as NEEDED
+# in the libicapapi.so ELF header in host libraries, which breaks the
+# build. The affected library is libz. Forcing AUTORECONF adds -lz to
+# the link command line, and that makes the linker look first in
+# sysroot, thus avoiding the build breakage.
+C_ICAP_AUTORECONF = YES
 
 ifeq ($(BR2_PACKAGE_BERKELEYDB),y)
 C_ICAP_CONF_OPTS += --with-berkeleydb