package/ntp: use common sysv init install
authorMatt Weber <matthew.weber@rockwellcollins.com>
Sun, 3 Feb 2019 22:38:51 +0000 (16:38 -0600)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Mon, 4 Feb 2019 14:14:18 +0000 (15:14 +0100)
Previously the sysv init script install was conditional based on ntpd
being selected, now that sntp also has an init script and could be
selected independent of ntpd, a common install is necessary.

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/ntp/ntp.mk

index aad1cdd6614eeba1ed01108bd393cc6c7de65df3..c62d59e81ac4635fabca1504884def1175ebaf74 100644 (file)
@@ -102,9 +102,8 @@ endef
 endif
 
 ifeq ($(BR2_PACKAGE_NTP_NTPD),y)
-define NTP_INSTALL_INIT_SYSV
+define NTP_INSTALL_INIT_SYSV_NTPD
        $(INSTALL) -D -m 755 package/ntp/S49ntp $(TARGET_DIR)/etc/init.d/S49ntp
-       $(NTP_INSTALL_INIT_SYSV_SNTP)
 endef
 
 define NTP_INSTALL_INIT_SYSTEMD
@@ -115,4 +114,9 @@ define NTP_INSTALL_INIT_SYSTEMD
 endef
 endif
 
+define NTP_INSTALL_INIT_SYSV
+       $(NTP_INSTALL_INIT_SYSV_NTPD)
+       $(NTP_INSTALL_INIT_SYSV_SNTP)
+endef
+
 $(eval $(autotools-package))