package/kmod: explicitly disable compression when not enabled
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 3 May 2020 13:09:59 +0000 (15:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 6 Oct 2020 19:43:26 +0000 (21:43 +0200)
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Yegor Yefremov <yegorslists@googlemail.com>
Tested-by: Matt Weber <matthew.weber@rockwellcollins.com>
Tested-by: Kris Bahnsen <kris@embeddedarm.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/kmod/kmod.mk

index 0a79b2cf4d1599a4e687e6667255952ab84ca78f..b27447192cb72f0536866e4f3f3a706e92a46bea 100644 (file)
@@ -35,11 +35,15 @@ endif
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 KMOD_DEPENDENCIES += zlib
 KMOD_CONF_OPTS += --with-zlib
+else
+KMOD_CONF_OPTS += --without-zlib
 endif
 
 ifeq ($(BR2_PACKAGE_XZ),y)
 KMOD_DEPENDENCIES += xz
 KMOD_CONF_OPTS += --with-xz
+else
+KMOD_CONF_OPTS += --without-xz
 endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)