package/apr: Add libuuid as optional dependency
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 21 May 2015 17:19:08 +0000 (19:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 21 May 2015 20:47:44 +0000 (22:47 +0200)
libuuid is picked up by apr when present:

Checking for OS UUID Support...
checking uuid/uuid.h usability... yes
checking uuid/uuid.h presence... yes
checking for uuid/uuid.h... yes
checking for library containing uuid_generate... -luuid
checking for uuid_generate... yes
checking for os uuid usability... yes

$ output/host/usr/bin/i586-buildroot-linux-uclibc-readelf -a output/target/usr/lib/libapr-1.so | grep libuuid
 0x00000001 (NEEDED)                     Shared library: [libuuid.so.1]

[Thomas: move the added chunk a bit further down, and use += instead
of =.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/apr/apr.mk

index 69524a6f3dc6f16b39e06e028ffaaf2d1eb61397..0fed19c54df9417dc8f1b0ba7a71aca59b8cec41 100644 (file)
@@ -12,6 +12,7 @@ APR_INSTALL_STAGING = YES
 # We have a patch touching configure.in and Makefile.in,
 # so we need to autoreconf:
 APR_AUTORECONF = YES
+
 APR_CONF_ENV = \
        CC_FOR_BUILD="$(HOSTCC)" \
        CFLAGS_FOR_BUILD="$(HOST_CFLAGS)" \
@@ -34,6 +35,10 @@ endif
 # Fix lfs detection when cross compiling
 APR_CONF_ENV += apr_cv_use_lfs64=yes
 
+ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
+APR_DEPENDENCIES += util-linux
+endif
+
 define APR_CLEANUP_UNNEEDED_FILES
        $(RM) -rf $(TARGET_DIR)/usr/build-1/
 endef