quagga: fix build with snmp support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 21 Feb 2011 19:25:06 +0000 (16:25 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 24 Feb 2011 08:14:29 +0000 (09:14 +0100)
Closes #3277

Quagga's snmp support tries to link with libcrypto from openssl by
default.
That's a bad no no since snmp might have ssl support disabled
and openssl won't be around.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/quagga/quagga.mk

diff --git a/CHANGES b/CHANGES
index 3858296f89e923fd4072d2d2ef3f3d0102717145..687561eeef480d2520e746465316e4a4b9eb37ba 100644 (file)
--- a/CHANGES
+++ b/CHANGES
        libcgicc, libdaemon, libdrm, libevent, libgail, libglib2,
        libgpg-error, libmicrohttpd, librsvg, libsoup, libxcp,
        makedevs, matchbox-fakekey, matchbox-startup-monitor, mdadm,
-       metacity, mpd, nasm, nfs-utils, olsr, popt, pthread-stubs,
-       quagga, rpm, samba, sdl, sdl_gfx, sdl_image, sdl_mixer,
-       sdl_sound, sdl_ttf, squashfs, taglib, tcpreplay, tiff,
-       wpa_supplicant, xcb-util,
+       metacity, mpd, nasm, nfs-utils, olsr, openssl, popt,
+       pthread-stubs, quagga, rpm, samba, sdl, sdl_gfx, sdl_image,
+       sdl_mixer, sdl_sound, sdl_ttf, squashfs, taglib, tcpreplay,
+       tiff, wpa_supplicant, xcb-util,
        xdriver_xf86-input-{acepad,aiptek,evdev,joystick,keyboard},
        xdriver_xf86-input-{mouse,synaptics,void},
        xdriver_xf86-video-{chips,dummy,geode,glide,intel,nv,wsfb},
@@ -27,6 +27,7 @@
        Issues resolved (http://bugs.uclibc.org):
 
        #3205: Failing chmod when running "make" in buildroot (openssl)...
+       #3277: quagga fails to build with SNMP support
        #3283: See why nfs-utils needs fakeroot, and convert to autotools
 
 2011.02-rc1, Released February 14th, 2011:
index d2b14440c81d47a4c31128f959a88cfad7061705..a807f0f4a76498db34050f51e72e75242a02074b 100644 (file)
@@ -67,6 +67,10 @@ endif
 ifeq ($(BR2_PACKAGE_QUAGGA_SNMP),y)
 QUAGGA_CONF_OPT+=--enable-snmp
 QUAGGA_DEPENDENCIES+=netsnmp
+# SNMP support tries -lcrypto by default, disable it if we ain't got openssl
+ifneq ($(BR2_PACKAGE_OPENSSL),y)
+QUAGGA_CONF_OPT+=--without-crypto
+endif
 else
 QUAGGA_CONF_OPT+=--disable-snmp
 endif