mplayer: fix build on i386
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 Nov 2011 21:14:53 +0000 (22:14 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 Nov 2011 21:14:53 +0000 (22:14 +0100)
Mplayer needs to be built with -fomit-frame-pointer on x86, otherwise
gcc errors out on the inline asm with too few registers.

Also disable yasm support, both because this mplayer revision forgets
to build the gpl'ed asm snippets (fixed in r32736), breaking the build
- And also to ensure the build is reproducable and doesn't use host
components behind the users' back (E.G. if yasm is available on host).

Once we have added yasm as a package, this can get removed again (and
mplayer svn rev bumped) for the performance boost it gives.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/mplayer/mplayer.mk

index 776cc68eea6b6d3e9ae0b2e2255efb94c58727a6..2ac5e16e2f25a8fbb74e8d3832b99ee6a04a8546 100644 (file)
@@ -108,6 +108,12 @@ ifeq ($(call qstrip,$(BR2_GCC_TARGET_ARCH)),armv7-a)
 MPLAYER_CONF_OPTS += --enable-neon
 endif
 
+ifeq ($(BR2_i386),y)
+# inline asm breaks with "can't find a register in class 'GENERAL_REGS'"
+# inless we free up ebp
+MPLAYER_CFLAGS += -fomit-frame-pointer
+endif
+
 define MPLAYER_CONFIGURE_CMDS
        (cd $(@D); rm -rf config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
@@ -122,6 +128,7 @@ define MPLAYER_CONFIGURE_CMDS
                --charset=UTF-8 \
                --extra-cflags="$(MPLAYER_CFLAGS)" \
                --extra-ldflags="$(MPLAYER_LDFLAGS)" \
+               --yasm='' \
                --enable-mad \
                --enable-fbdev \
                $(MPLAYER_CONF_OPTS) \