cairo: fix m68k uclinux compile
authorWaldemar Brodkorb <wbx@openadk.org>
Mon, 8 Aug 2016 04:46:17 +0000 (06:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 8 Aug 2016 21:46:54 +0000 (23:46 +0200)
The GCC manual suggest when getting:
relocation truncated to fit: R_68K_GOT16O foobar
to use -mxgot.

Fixes:
  http://autobuild.buildroot.net/results/31a488316fe3c14729a6dd9259205f8530684cab/
  http://autobuild.buildroot.net/results/dc6b899e3e502d65b2cf2f6d922a4f63857edf82/

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cairo/cairo.mk

index b79899565b78555be813c4259a1dd07a20a66144..d7e370ae70694efb25f2bd82eeb166bc062fb18f 100644 (file)
@@ -12,6 +12,11 @@ CAIRO_SITE = http://cairographics.org/releases
 CAIRO_INSTALL_STAGING = YES
 CAIRO_AUTORECONF = YES
 
+# relocation truncated to fit: R_68K_GOT16O
+ifeq ($(BR2_m68k_cf),y)
+CAIRO_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -mxgot"
+endif
+
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
 CAIRO_CONF_ENV += CPPFLAGS="$(TARGET_CPPFLAGS) -DCAIRO_NO_MUTEX=1"
 endif