mpd: add optional support for libshout
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 31 Aug 2016 22:16:55 +0000 (00:16 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 31 Aug 2016 22:18:27 +0000 (00:18 +0200)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mpd/Config.in
package/mpd/mpd.mk

index 2ea21fc6aef38ad16af804232ced0101dbc8d812..82bbd8d21fea8d76d9edf7ca431b8ea21aefe0e0 100644 (file)
@@ -262,6 +262,12 @@ comment "pulseaudio support needs a toolchain w/ dynamic library"
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on BR2_STATIC_LIBS
 
+config BR2_PACKAGE_MPD_SHOUTCAST
+       bool "shoutcast"
+       select BR2_PACKAGE_LIBSHOUT
+       help
+         Enable shoutcast streaming output support.
+
 comment "Miscellaneous plugins"
 
 config BR2_PACKAGE_MPD_AVAHI_SUPPORT
index 6e2cf8c90ea66d57863838b4337eaff739f0525f..845b749da98208c7a5f7721af038b4b7c7c7a032 100644 (file)
@@ -195,6 +195,13 @@ else
 MPD_CONF_OPTS += --disable-pulse
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_SHOUTCAST),y)
+MPD_DEPENDENCIES += libshout
+MPD_CONF_OPTS += --enable-shout
+else
+MPD_CONF_OPTS += --disable-shout
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_SOUNDCLOUD),y)
 MPD_DEPENDENCIES += yajl
 MPD_CONF_OPTS += --enable-soundcloud