xserver: libdrm is not needed for tinyx
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 20 Jul 2010 21:29:42 +0000 (23:29 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 20 Jul 2010 21:29:42 +0000 (23:29 +0200)
libdrm is only needed for the modular server, and as libdrm
needs largefile support and tinyx doesn't, this dependency could
cause a build failure.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/x11r7/xserver_xorg-server/Config.in
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index 8a8d10f3f8a0bc2e15fecfa62f8bde97402d7d64..2d725e4483611ae1ea8612235191feabeeeebd7f 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_XSERVER_XORG_SERVER
        bool "xorg-server"
-       select BR2_PACKAGE_LIBDRM
+       select BR2_PACKAGE_LIBDRM if BR2_PACKAGE_XSERVER_xorg
        select BR2_PACKAGE_MCOOKIE
        select BR2_PACKAGE_OPENSSL
        select BR2_PACKAGE_PIXMAN
index b0bc48b356525389bd21db2b4ef2899c68b44f8f..e32215f000eaeaeda056bce244a35c4ade8b4dc7 100644 (file)
@@ -53,7 +53,6 @@ XSERVER_XORG_SERVER_DEPENDENCIES =    \
        xproto_xf86rushproto            \
        xproto_xf86vidmodeproto         \
        xproto_xproto                   \
-       libdrm                          \
        pixman                          \
        openssl                         \
        mcookie
@@ -65,7 +64,7 @@ XSERVER_XORG_SERVER_CONF_OPT = --disable-config-hal \
 
 ifeq ($(BR2_PACKAGE_XSERVER_xorg),y)
 XSERVER_XORG_SERVER_CONF_OPT += --enable-xorg --disable-glx
-XSERVER_XORG_SERVER_DEPENDENCIES += xlib_libpciaccess
+XSERVER_XORG_SERVER_DEPENDENCIES += xlib_libpciaccess libdrm
 else
 XSERVER_XORG_SERVER_CONF_OPT += --disable-xorg
 endif