package/rp-pppoe: bump to version 3.14
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 13 Jul 2020 21:17:10 +0000 (23:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 14 Jul 2020 13:06:03 +0000 (15:06 +0200)
Update patch and renumber it

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/rp-pppoe/0001-krn-plugin.patch [new file with mode: 0644]
package/rp-pppoe/0002-krn-plugin.patch [deleted file]
package/rp-pppoe/rp-pppoe.hash
package/rp-pppoe/rp-pppoe.mk

diff --git a/package/rp-pppoe/0001-krn-plugin.patch b/package/rp-pppoe/0001-krn-plugin.patch
new file mode 100644 (file)
index 0000000..c386e85
--- /dev/null
@@ -0,0 +1,27 @@
+[Fabrice: update patch for 3.14]
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+diff -Nura rp-pppoe-3.11.orig/src/configure rp-pppoe-3.11/src/configure
+--- rp-pppoe-3.11.orig/src/configure   2012-08-21 10:01:10.536440032 -0300
++++ rp-pppoe-3.11/src/configure        2012-08-21 10:01:45.353442397 -0300
+@@ -4517,7 +4517,7 @@
+ modprobe pppoe > /dev/null 2>&1
+ fi
+ if test "$cross_compiling" = yes; then :
+-  ac_cv_linux_kernel_pppoe=no; echo "cross-compiling, default: "
++  ac_cv_linux_kernel_pppoe=yes; echo "cross-compiling, default: "
+ else
+   cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h.  */
+diff -Nura rp-pppoe-3.11.orig/src/pppoe-server.c rp-pppoe-3.11/src/pppoe-server.c
+--- rp-pppoe-3.11.orig/src/pppoe-server.c      2012-08-21 10:01:10.535440032 -0300
++++ rp-pppoe-3.11/src/pppoe-server.c   2012-08-21 10:02:02.597443569 -0300
+@@ -20,6 +20,9 @@
+ #include "config.h"
++/* Patched hack to make this cross compile */
++#define HAVE_LINUX_KERNEL_PPPOE 1
++
+ #if defined(HAVE_NETPACKET_PACKET_H) || defined(HAVE_LINUX_IF_PACKET_H)
+ #define _POSIX_SOURCE 1 /* For sigaction defines */
+ #endif
diff --git a/package/rp-pppoe/0002-krn-plugin.patch b/package/rp-pppoe/0002-krn-plugin.patch
deleted file mode 100644 (file)
index d364e86..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -Nura rp-pppoe-3.11.orig/src/configure rp-pppoe-3.11/src/configure
---- rp-pppoe-3.11.orig/src/configure   2012-08-21 10:01:10.536440032 -0300
-+++ rp-pppoe-3.11/src/configure        2012-08-21 10:01:45.353442397 -0300
-@@ -4517,7 +4517,7 @@
- modprobe pppoe > /dev/null 2>&1
- fi
- if test "$cross_compiling" = yes; then :
--  ac_cv_linux_kernel_pppoe=no; $ECHO "cross-compiling, default: "
-+  ac_cv_linux_kernel_pppoe=yes; $ECHO "cross-compiling, default: "
- else
-   cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h.  */
-diff -Nura rp-pppoe-3.11.orig/src/pppoe-server.c rp-pppoe-3.11/src/pppoe-server.c
---- rp-pppoe-3.11.orig/src/pppoe-server.c      2012-08-21 10:01:10.535440032 -0300
-+++ rp-pppoe-3.11/src/pppoe-server.c   2012-08-21 10:02:02.597443569 -0300
-@@ -20,6 +20,9 @@
- #include "config.h"
-+/* Patched hack to make this cross compile */
-+#define HAVE_LINUX_KERNEL_PPPOE 1
-+
- #if defined(HAVE_NETPACKET_PACKET_H) || defined(HAVE_LINUX_IF_PACKET_H)
- #define _POSIX_SOURCE 1 /* For sigaction defines */
- #endif
index 3f7af60558dbd692148be2ea5b50aa7dd83eea41..806bab1b0f574828f510286f76ae932b0fde3821 100644 (file)
@@ -1,4 +1,4 @@
 # Locally calculated after checking pgp signature
-sha256  00794e04031546b0e9b8cf286f2a6d1ccfc4a621b2a3abb2d7ef2a7ab7cc86c2  rp-pppoe-3.12.tar.gz
+sha256  7825232f64ab4d618ef074d62d145ae43d6edc91b9a718c6130a4742bac40e2a  rp-pppoe-3.14.tar.gz
 # Locally computed
 sha256  464006ba771074f4022db14f58a29a0b447b6fdde9529cf0331be396b6279162  doc/LICENSE
index 4214df929f23e9ecb92bc9bb009ed745c0b87927..2f0073b6c0292120dcc05744782c0a5a21f08925 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-RP_PPPOE_VERSION = 3.12
-RP_PPPOE_SITE = http://www.roaringpenguin.com/files/download
+RP_PPPOE_VERSION = 3.14
+RP_PPPOE_SITE = https://dianne.skoll.ca/projects/rp-pppoe/download
 RP_PPPOE_LICENSE = GPL-2.0
 RP_PPPOE_LICENSE_FILES = doc/LICENSE
 RP_PPPOE_DEPENDENCIES = pppd