Makefile: add new missing-cpe target
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 31 Jan 2021 13:38:18 +0000 (14:38 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 16 May 2021 11:58:36 +0000 (13:58 +0200)
It invokes the recently introduced gen-missing-cpe script.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Makefile

index 76f14888eaabf5b222ae87b715b70d3eeda5c9b8..75ef7f5eb518e3e5e2a73f67635184663e45fc60 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -945,6 +945,14 @@ pkg-stats:
                --html $(O)/pkg-stats.html \
                --nvd-path $(DL_DIR)/buildroot-nvd
 
+.PHONY: missing-cpe
+missing-cpe:
+       $(Q)mkdir -p $(O)/cpe-updates
+       $(Q)cd "$(CONFIG_DIR)" ; \
+       $(TOPDIR)/support/scripts/gen-missing-cpe \
+               --nvd-path $(DL_DIR)/buildroot-nvd \
+               --output $(O)/cpe-updates
+
 else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
 
 # Some subdirectories are also package names. To avoid that "make linux"
@@ -1163,6 +1171,7 @@ help:
        @echo '  legal-info             - generate info about license compliance'
        @echo '  show-info              - generate info about packages, as a JSON blurb'
        @echo '  pkg-stats              - generate info about packages as JSON and HTML'
+       @echo '  missing-cpe            - generate XML snippets for missing CPE identifiers'
        @echo '  printvars              - dump internal variables selected with VARS=...'
        @echo
        @echo '  make V=0|1             - 0 => quiet build (default), 1 => verbose build'