weston: add EGL support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 29 Mar 2016 14:39:00 +0000 (11:39 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Mar 2016 14:57:48 +0000 (16:57 +0200)
Also drop simple-egl-clients from the rpi compositor since it's a
duplicate of the global one.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/weston/weston.mk

index d81807194b0df18e7fd1f8f28d536980d8e43d27..e7ad97e10e0fe5ddbc95bf66c9e41930792e2983 100644 (file)
@@ -15,7 +15,6 @@ WESTON_DEPENDENCIES = host-pkgconf wayland wayland-protocols \
 
 WESTON_CONF_OPTS = \
        --with-dtddir=$(STAGING_DIR)/usr/share/wayland \
-       --disable-egl \
        --disable-simple-egl-clients \
        --disable-xwayland \
        --disable-x11-compositor \
@@ -28,6 +27,14 @@ WESTON_CONF_OPTS = \
 WESTON_MAKE_OPTS = \
        WAYLAND_PROTOCOLS_DATADIR=$(STAGING_DIR)/usr/share/wayland-protocols
 
+# Needs wayland-egl, which normally only mesa provides
+ifeq ($(BR2_PACKAGE_HAS_LIBEGL)$(BR2_PACKAGE_MESA3D_OPENGL_EGL),yy)
+WESTON_CONF_OPTS += --enable-egl
+WESTON_DEPENDENCIES += libegl
+else
+WESTON_CONF_OPTS += --disable-egl
+endif
+
 ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
 WESTON_DEPENDENCIES += libunwind
 else
@@ -53,7 +60,6 @@ WESTON_CONF_OPTS += --enable-rpi-compositor \
        --disable-resize-optimization \
        --disable-setuid-install \
        --disable-xwayland-test \
-       --disable-simple-egl-clients \
        WESTON_NATIVE_BACKEND=rpi-backend.so
 else
 WESTON_CONF_OPTS += --disable-rpi-compositor