package/pkg-python: fix python 3.8.0 package builds
authorJames Hilliard <james.hilliard1@gmail.com>
Thu, 17 Oct 2019 16:21:27 +0000 (10:21 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 19 Oct 2019 19:06:56 +0000 (21:06 +0200)
We need to update the sysconfigdata path for python 3.8.0 per upstream
commit 7efc526e5cfb929a79c192ac2dcf7eb78d3a4401 which indicates the "m"
flag has been removed from sys.abiflags.

Fixes this build error when building target packages:
ValueError: Empty module name

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-python.mk

index e9069204173cd64f87d8a240bf6f377c6d694c4a..be1ce071dff06319557540130c3e65622556b6e6 100644 (file)
@@ -21,7 +21,7 @@
 ################################################################################
 
 define PKG_PYTHON_SYSCONFIGDATA_NAME
-$(basename $(notdir $(wildcard $(STAGING_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)/_sysconfigdata_m_linux_*.py)))
+$(basename $(notdir $(wildcard $(STAGING_DIR)/usr/lib/python$(PYTHON3_VERSION_MAJOR)/_sysconfigdata__linux_*.py)))
 endef
 
 # Target distutils-based packages