package/sconeserver: disable image
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 21 Mar 2021 11:47:12 +0000 (12:47 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Mon, 26 Apr 2021 19:59:39 +0000 (21:59 +0200)
Build of http::sconesite::image module was silently broken until commit
d3b818c3cf0990117a8b59fcfc6c212f310ae6ec

However, sconeserver fails to build with ImageMagick because:
- it checks for ImageMagick++.pc instead of ImageMagick.pc
- it uses the transform function which has been removed from the public
  API since version 7.0.1-0 and
  https://github.com/ImageMagick/ImageMagick/commit/06f590165f0505d42005264893fe14a9e8a79986

As sconeserver does not seem to be maintained anymore, drop
BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE_IMAGE.

Fixes:
 - http://autobuild.buildroot.org/results/895ab582d1140f7677fc1c6934fa2e0c47c49f20

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
[Arnout: add legacy symbol. It costs us exactly nothing, and if someone
actually had that selected, they know what's going on.]

Config.in.legacy
package/sconeserver/Config.in
package/sconeserver/sconeserver.mk

index c2b0645eaf05ef7c6b3e762ba914b6f8af9eee52..038796731196f24bfc1d1abeb5ba4b167c6aa2c6 100644 (file)
@@ -146,6 +146,12 @@ endif
 
 comment "Legacy options removed in 2021.05"
 
+config BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE_IMAGE
+       bool "sconeserver http::sconesite::image removed"
+       help
+         Sconeserver cannot be built with ImageMagick - it uses the
+         "transofrm" function which is removed from public API.
+
 config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE_EVDEV
        bool "KDrive/TinyX evdev input driver removed"
        select BR2_LEGACY
index 429ac81fe19cbacdd014d84149ac1d6f22645cf3..d46ba85fbcd19e9b1dd235482ded583424116c51 100644 (file)
@@ -26,14 +26,6 @@ config BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE
        help
          http::sconesite module for Sconeserver
 
-config BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE_IMAGE
-       bool "http::sconesite::image"
-       depends on BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE
-       depends on BR2_USE_MMU # imagemagick
-       select BR2_PACKAGE_IMAGEMAGICK
-       help
-         http::sconesite::image module for Sconeserver
-
 config BR2_PACKAGE_SCONESERVER_MYSQL
        bool "mysql"
        depends on BR2_USE_MMU # mysql
index 62cc128d77c086eac6bdaac507cfc42cae59d958..17407c29f512047c9af19f1acb3919e2e924d498 100644 (file)
@@ -14,10 +14,16 @@ SCONESERVER_DEPENDENCIES = \
        host-pkgconf \
        $(if $(BR2_PACKAGE_PCRE),pcre) \
        zlib
+# disable image as it fails to build with ImageMagick
 # disable markdown module because its git submodule cmark
 # https://github.com/sconemad/sconeserver/tree/master/markdown
 # has no cross-compile support provided by the sconeserver build system
-SCONESERVER_CONF_OPTS += --with-ip --with-local --with-ip6 --without-markdown
+SCONESERVER_CONF_OPTS += \
+       --with-ip \
+       --with-local \
+       --with-ip6 \
+       --without-image \
+       --without-markdown
 
 # Sconeserver configure script fails to find the libxml2 headers.
 ifeq ($(BR2_PACKAGE_LIBXML2),y)
@@ -45,13 +51,6 @@ else
 SCONESERVER_CONF_OPTS += --without-sconesite
 endif
 
-ifeq ($(BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE_IMAGE),y)
-SCONESERVER_DEPENDENCIES += imagemagick
-SCONESERVER_CONF_OPTS += --with-image
-else
-SCONESERVER_CONF_OPTS += --without-image
-endif
-
 ifeq ($(BR2_PACKAGE_SCONESERVER_MYSQL),y)
 SCONESERVER_DEPENDENCIES += mysql
 SCONESERVER_CONF_OPTS += \