arp-scan: new package
authorArnout Vandecappelle <arnout@mind.be>
Wed, 5 Apr 2017 10:14:10 +0000 (12:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 5 Apr 2017 21:11:26 +0000 (23:11 +0200)
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/arp-scan/0001-configure-try-linking-to-detect-stack-protector-supp.patch [new file with mode: 0644]
package/arp-scan/Config.in [new file with mode: 0644]
package/arp-scan/arp-scan.hash [new file with mode: 0644]
package/arp-scan/arp-scan.mk [new file with mode: 0644]

index fbc70e57c7832b2a116acc421b554ef6a0f3a5e2..e1713cf4c39d441256a88dcc0aa7395a3a818ec1 100644 (file)
@@ -104,6 +104,7 @@ N:  Arnaud Aujon <arnaud@intelibre.fr>
 F:     package/espeak/
 
 N:     Arnout Vandecappelle <arnout@mind.be>
+F:     package/arp-scan/
 F:     package/freescale-imx/firmware-imx/
 F:     package/freescale-imx/imx-lib/
 F:     package/gstreamer/gst-fsl-plugins/
index 71bd44a53a83992989e8895d2d1cead701cda262..fe4c0ae4bc5c68716c38ce0d6ee65f48592bf55d 100644 (file)
@@ -1494,6 +1494,7 @@ menu "Networking applications"
        source "package/aircrack-ng/Config.in"
        source "package/apache/Config.in"
        source "package/argus/Config.in"
+       source "package/arp-scan/Config.in"
        source "package/arptables/Config.in"
        source "package/atftp/Config.in"
        source "package/autossh/Config.in"
diff --git a/package/arp-scan/0001-configure-try-linking-to-detect-stack-protector-supp.patch b/package/arp-scan/0001-configure-try-linking-to-detect-stack-protector-supp.patch
new file mode 100644 (file)
index 0000000..8eb9d6e
--- /dev/null
@@ -0,0 +1,39 @@
+From f406041b58eadc716d6227408d3af553d566ffeb Mon Sep 17 00:00:00 2001
+From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>
+Date: Tue, 4 Apr 2017 17:31:29 +0200
+Subject: [PATCH] configure: try linking to detect stack-protector support
+
+Even if gcc accepts the -fstack-protector argument, it is possible that
+the libssp support library is missing. Detect this by linking instead
+of just compiling.
+
+Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
+---
+ acinclude.m4 | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/acinclude.m4 b/acinclude.m4
+index 3c84118..4725154 100644
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -243,7 +243,7 @@ AC_DEFUN([GCC_STACK_PROTECT_CC],[
+     AC_MSG_CHECKING([whether ${CC} accepts -fstack-protector])
+     ssp_old_cflags="$CFLAGS"
+     CFLAGS="$CFLAGS -fstack-protector"
+-    AC_TRY_COMPILE(,,, ssp_cc=no)
++    AC_TRY_LINK(,,, ssp_cc=no)
+     echo $ssp_cc
+     if test "X$ssp_cc" = "Xno"; then
+       CFLAGS="$ssp_old_cflags"
+@@ -259,7 +259,7 @@ AC_DEFUN([GCC_STACK_PROTECT_CXX],[
+     AC_MSG_CHECKING([whether ${CXX} accepts -fstack-protector])
+     ssp_old_cxxflags="$CXXFLAGS"
+     CXXFLAGS="$CXXFLAGS -fstack-protector"
+-    AC_TRY_COMPILE(,,, ssp_cxx=no)
++    AC_TRY_LINK(,,, ssp_cxx=no)
+     echo $ssp_cxx
+     if test "X$ssp_cxx" = "Xno"; then
+         CXXFLAGS="$ssp_old_cxxflags"
+-- 
+2.11.0
+
diff --git a/package/arp-scan/Config.in b/package/arp-scan/Config.in
new file mode 100644 (file)
index 0000000..cc47a72
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_ARP_SCAN
+       bool "arp-scan"
+       select BR2_PACKAGE_LIBPCAP
+       help
+         The ARP scanner
+
+         arp-scan is a command-line tool that uses the ARP protocol to
+         discover and fingerprint IP hosts on the local network.
+
+         http://www.nta-monitor.com/wiki/index.php/Arp-scan_Documentation
diff --git a/package/arp-scan/arp-scan.hash b/package/arp-scan/arp-scan.hash
new file mode 100644 (file)
index 0000000..4b2ddf1
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 ce908ac71c48e85dddf6dd4fe5151d13c7528b1f49717a98b2a2535bd797d892        arp-scan-1.9.tar.gz
diff --git a/package/arp-scan/arp-scan.mk b/package/arp-scan/arp-scan.mk
new file mode 100644 (file)
index 0000000..fc3740b
--- /dev/null
@@ -0,0 +1,18 @@
+################################################################################
+#
+# arp-scan
+#
+################################################################################
+
+ARP_SCAN_VERSION = 1.9
+ARP_SCAN_SITE = https://github.com/royhills/arp-scan/releases/download/$(ARP_SCAN_VERSION)
+ARP_SCAN_LICENSE = GPL-3.0+
+ARP_SCAN_LICENSE_FILES = COPYING
+ARP_SCAN_DEPENDENCIES = libpcap
+
+# 0001-configure-try-linking-to-detect-stack-protector-supp.patch touches acinclude.m4
+ARP_SCAN_AUTORECONF = YES
+
+ARP_SCAN_CONF_ENV = pgac_cv_snprintf_long_long_int_format='%lld'
+
+$(eval $(autotools-package))