polarssl: security bump to version 1.2.9
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 7 Oct 2013 12:18:16 +0000 (09:18 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 7 Oct 2013 20:08:27 +0000 (22:08 +0200)
Fixes PolarSSL SA 2013-05.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/polarssl/polarssl-shared-and-static-library.patch
package/polarssl/polarssl.mk

index f376c1e9ffd9f2e0cb33177ffc8453bcf9d96706..47511b24d574dc953e8586e671c4cde2f5159cc9 100644 (file)
@@ -9,7 +9,7 @@ This patch adds the USE_STATIC_POLARSSL_LIBRARY (which defaults to ON)
 in addition to the existing USE_SHARED_POLARSSL_LIBRARY (which
 defaults to OFF). Both options can be manipulated independently.
 
-[Gustavo: update for polarssl 1.2.8]
+[Gustavo: update for polarssl 1.2.9]
 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
 
@@ -34,7 +34,7 @@ diff -Nura polarssl-1.2.3.orig/library/CMakeLists.txt polarssl-1.2.3/library/CMa
 +if(USE_SHARED_POLARSSL_LIBRARY)
  
  add_library(polarssl SHARED ${src})
- set_target_properties(polarssl PROPERTIES VERSION 1.2.8 SOVERSION 2)
+ set_target_properties(polarssl PROPERTIES VERSION 1.2.9 SOVERSION 3)
 +set_target_properties(polarssl PROPERTIES OUTPUT_NAME polarssl)
 +
 +endif(USE_SHARED_POLARSSL_LIBRARY)
index 781b6bc48e7dd759839347911115c328c4ca3a4a..deb2252a536f559131a25386bbd2d97771e85d34 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 POLARSSL_SITE = https://polarssl.org/code/releases
-POLARSSL_VERSION = 1.2.8
+POLARSSL_VERSION = 1.2.9
 POLARSSL_SOURCE = polarssl-$(POLARSSL_VERSION)-gpl.tgz
 POLARSSL_CONF_OPT = \
        -DUSE_SHARED_POLARSSL_LIBRARY=ON \