xtensa: use uppercase for configurations and modified overlay structure
authorChris Zankel <chris@zankel.net>
Tue, 20 Nov 2012 08:31:36 +0000 (08:31 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 21 Nov 2012 10:08:50 +0000 (11:08 +0100)
Except for architecture and processor names, buildroot uses capitalized
configuration names, so change the macro names for xtensa to follow that
standard.
Change the overlay file to have a subdirectory for each component
(gdb, binutils, gcc, etc.) to make it more future-prove.

Signed-off-by: Chris Zankel <chris@zankel.net>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
arch/Config.in.xtensa
package/binutils/binutils.mk
toolchain/gcc/gcc-uclibc-4.x.mk
toolchain/gdb/gdb.mk

index af66125cbd35b742d35f1e2293916e254fb0af4a..60c03f5515f6f2d921f6e68013f4f8bb73113464 100644 (file)
@@ -2,32 +2,36 @@ choice
        prompt "Target Architecture Variant"
        depends on BR2_xtensa
        default BR2_xtensa_fsf
-config BR2_xtensa_custom
+config BR2_XTENSA_CUSTOM
        bool "Custom Xtensa processor configuration"
 config BR2_xtensa_fsf
        bool "fsf - Default configuration"
 endchoice
 
-config BR2_xtensa_custom_name
-       string "Custom Xtensa processor configuration anme"
-       depends on BR2_xtensa_custom
+config BR2_XTENSA_CUSTOM_NAME
+       string "Custom Xtensa processor configuration name"
+       depends on BR2_XTENSA_CUSTOM
        default ""
        help
          Name given to a custom Xtensa processor configuration.
 
-config BR2_xtensa_core_name
+config BR2_XTENSA_CORE_NAME
        string
-       default BR2_xtensa_custom_name  if BR2_xtensa_custom
+       default BR2_XTENSA_CUSTOM_NAME  if BR2_XTENSA_CUSTOM
        default ""                      if BR2_xtensa_fsf
 
-config BR2_xtensa_overlay_dir
+config BR2_XTENSA_OVERLAY_DIR
        string "Overlay directory for custom configuration"
-       depends on BR2_xtensa_custom
+       depends on BR2_XTENSA_CUSTOM
        default ""
        help
-         Provide a directory path that contains the overlay files
-         for the custom configuration. The path is based on the
-         buildroot top directory.
+         Provide the directory path that contains the overlay file
+         for a custom processor configuration. The path is relative
+         to the top directory of buildroot.
+         These overlay files are tar packages with updated configuration
+         files for various toolchain packages and Xtensa processor
+         configurations. They are provided by the processor vendor or
+         directly from Tensilica.
 
 config BR2_ARCH
        default "xtensa"        if BR2_xtensa
index 82f8fd2346bde91a6b09e1c6d8c4eb0744269272..92e0a74836507f9e00b7385808ff79f07357d33d 100644 (file)
@@ -68,11 +68,11 @@ define BINUTILS_INSTALL_TARGET_CMDS
 endef
 endif
 
-XTENSA_CORE_NAME = $(call qstrip, $(BR2_xtensa_core_name))
+XTENSA_CORE_NAME = $(call qstrip, $(BR2_XTENSA_CORE_NAME))
 ifneq ($(XTENSA_CORE_NAME),)
 define BINUTILS_XTENSA_PRE_PATCH
-       tar xf $(BR2_xtensa_overlay_dir)/xtensa_$(XTENSA_CORE_NAME).tar \
-               -C $(@D) bfd include ld
+       tar xf $(BR2_XTENSA_OVERLAY_DIR)/xtensa_$(XTENSA_CORE_NAME).tar \
+               -C $(@D) --strip-components=1 binutils
 endef
 HOST_BINUTILS_PRE_PATCH_HOOKS += BINUTILS_XTENSA_PRE_PATCH
 endif
index 1710070edda41755f76975419e4209e1231e3dfd..7a0b4caa09e746ffc686bea6095a2f6d10507a25 100644 (file)
@@ -251,9 +251,9 @@ $(GCC_DIR)/.unpacked: $(DL_DIR)/$(GCC_SOURCE)
        rm -rf $(GCC_DIR)
        $(GCC_CAT) $(DL_DIR)/$(GCC_SOURCE) | tar -C $(TOOLCHAIN_DIR) $(TAR_OPTIONS) -
        $(call CONFIG_UPDATE,$(@D))
-ifneq ($(call qstrip, $(BR2_xtensa_core_name)),)
-       tar xf $(BR2_xtensa_overlay_dir)/xtensa_$(call qstrip,\
-               $(BR2_xtensa_core_name)).tar -C $(@D) include
+ifneq ($(call qstrip, $(BR2_XTENSA_CORE_NAME)),)
+       tar xf $(BR2_XTENSA_OVERLAY_DIR)/xtensa_$(call qstrip,\
+               $(BR2_XTENSA_CORE_NAME)).tar -C $(@D) --strip-components=1 gcc
 endif
        touch $@
 
index dc305a63bf791ee2d93b21af2b2b90896ff2a59c..c42c755467d6740c0e9a89cb567f641ca8a49e64 100644 (file)
@@ -25,9 +25,9 @@ gdb-unpacked: $(GDB_DIR)/.unpacked
 $(GDB_DIR)/.unpacked: $(DL_DIR)/$(GDB_SOURCE)
        mkdir -p $(GDB_DIR)
        $(GDB_CAT) $(DL_DIR)/$(GDB_SOURCE) | tar -C $(GDB_DIR) $(TAR_STRIP_COMPONENTS)=1 $(TAR_OPTIONS) -
-ifneq ($(call qstrip, $(BR2_xtensa_core_name)),)
-       tar xf $(BR2_xtensa_overlay_dir)/xtensa_$(call qstrip, \
-               $(BR2_xtensa_core_name)).tar -C $(@D) bfd include gdb
+ifneq ($(call qstrip, $(BR2_XTENSA_CORE_NAME)),)
+       tar xf $(BR2_XTENSA_OVERLAY_DIR)/xtensa_$(call qstrip, \
+               $(BR2_XTENSA_CORE_NAME)).tar -C $(@D) --strip-components=1 gdb
 endif
 ifneq ($(wildcard $(GDB_PATCH_DIR)),)
        support/scripts/apply-patches.sh $(GDB_DIR) $(GDB_PATCH_DIR) \*.patch