package/vlc: add fluidsynth optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 10 Jan 2020 22:02:36 +0000 (23:02 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 11 Jan 2020 14:46:31 +0000 (15:46 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index ae12e89b8a976f89f8ace1c961df7fdc36a4ec7d..4b1cd68d8b1652d4555b1bba4c355810ec99c9a8 100644 (file)
@@ -55,7 +55,6 @@ VLC_CONF_OPTS += \
        --disable-dsm \
        --disable-dv1394 \
        --disable-fluidlite \
-       --disable-fluidsynth \
        --disable-gme \
        --disable-goom \
        --disable-jack \
@@ -164,6 +163,13 @@ else
 VLC_CONF_OPTS += --disable-flac
 endif
 
+ifeq ($(BR2_PACKAGE_FLUIDSYNTH),y)
+VLC_CONF_OPTS += --enable-fluidsynth
+VLC_DEPENDENCIES += fluidsynth
+else
+VLC_CONF_OPTS += --disable-fluidsynth
+endif
+
 ifeq ($(BR2_PACKAGE_FREERDP),y)
 VLC_CONF_OPTS += --enable-freerdp
 VLC_DEPENDENCIES += freerdp