Makefile: test before search for kernel modules
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 20 Aug 2013 11:03:02 +0000 (13:03 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 23 Aug 2013 18:42:40 +0000 (20:42 +0200)
The 'find $(TARGET_DIR)/lib/modules' used to find and strip kernel
modules fails when no kernel modules have been installed. While the
'|| true' prevents the entire build from failing, there are still some
error messages displayed, which is not nice.

Instead, test if the directory exists before doing the find. We also
remove the '|| true' in order to really abort the build if a
problematic error occurs.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: Luca Ceresoli <luca@lucaceresoli.net>
Makefile

index 6018d63f696f7d81d02ef72f9e4d9fe19c3aad65..9f0164ed6c4172e987246004d2b088f4ec7e1645 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -476,8 +476,9 @@ ifeq ($(BR2_PACKAGE_PYTHON_PYC_ONLY),y)
        find $(TARGET_DIR)/usr/lib/ -name '*.py' -print0 | xargs -0 rm -f
 endif
        $(STRIP_FIND_CMD) | xargs $(STRIPCMD) 2>/dev/null || true
-       find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \
-               xargs -r $(KSTRIPCMD) || true
+       test -d $(TARGET_DIR)/lib/modules && \
+               find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \
+               xargs -r $(KSTRIPCMD)
 
 # See http://sourceware.org/gdb/wiki/FAQ, "GDB does not see any threads
 # besides the one in which crash occurred; or SIGTRAP kills my program when