package/samba4: fix build without python3
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 15 Dec 2019 17:36:29 +0000 (18:36 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 22 Dec 2019 22:29:08 +0000 (23:29 +0100)
python3 is mandatory since version 4.11 and
https://gitlab.com/samba-team/samba/commit/63d20d7822ead1626f7cb41fdbae6c9300893314

The only way to build samba4 without python3 is to disable python
bindings through --disable-python option

Fixes:
 - http://autobuild.buildroot.org/results/c4bb3d41fa07e38f0360a563bdcb4a368740cfe5

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/samba4/samba4.mk

index bf9636f6e8770d2ff1d7e7c8f48636864e6e3fbf..955de8f764c8b8ee003f1a6fe2d42ab7aabf5595 100644 (file)
@@ -31,10 +31,9 @@ SAMBA4_PYTHON = \
        PYTHON_CONFIG="$(STAGING_DIR)/usr/bin/python3-config"
 SAMBA4_DEPENDENCIES += host-python3 python3
 else
-SAMBA4_PYTHON = \
-       PYTHON="$(HOST_DIR)/bin/python2" \
-       PYTHON_CONFIG="$(STAGING_DIR)/usr/bin/python-config"
-SAMBA4_DEPENDENCIES += host-python python
+SAMBA4_PYTHON = PYTHON="$(HOST_DIR)/bin/python2" 
+SAMBA4_DEPENDENCIES += host-python
+SAMBA4_CONF_OPTS += --disable-python
 endif
 
 ifeq ($(BR2_PACKAGE_LIBTIRPC),y)