package/matchbox: xlib-libXcursor is an optional dependency
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 3 Jun 2015 20:41:45 +0000 (22:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 9 Jun 2015 21:09:13 +0000 (23:09 +0200)
matchbox selects xlib-libXcursor, but does not build-depend on it.

But xlib-libXcursor is only an optional dependency.

Fix that by removing the select, and properly build-depend on it when
it is enabled.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/matchbox/Config.in
package/matchbox/matchbox.mk

index 0c7e5ea9f9133bec4a4aca3d452f7e4c25997ec8..3a9f118f4a72f148d312d21c82049199397f7155 100644 (file)
@@ -4,7 +4,6 @@ menuconfig BR2_PACKAGE_MATCHBOX
        depends on BR2_USE_MMU # fork()
        select BR2_PACKAGE_FONTCONFIG
        select BR2_PACKAGE_EXPAT
-       select BR2_PACKAGE_XLIB_LIBXCURSOR
        select BR2_PACKAGE_MATCHBOX_LIB
        help
          Matchbox is an Open Source base environment for the X Window
index 1abcfd8482fe93d6c73bf2ede3f51f5a9d7e1e97..3b6a0eb388c67d39ca735d1263561398e7185552 100644 (file)
@@ -35,4 +35,8 @@ else
 MATCHBOX_CONF_OPTS += --disable-session
 endif
 
+ifeq ($(BR2_PACKAGE_XLIB_LIBXCURSOR),y)
+MATCHBOX_DEPENDENCIES += xlib_libXcursor
+endif
+
 $(eval $(autotools-package))