package/sdl2: enable 3DNOW only if it's supported by the target
authorNicolas Robin <nrosfs@gmail.com>
Fri, 15 May 2020 17:53:57 +0000 (19:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 15 May 2020 19:47:55 +0000 (21:47 +0200)
Signed-off-by: Nicolas Robin <nrosfs@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sdl2/sdl2.mk

index 4a287b66a39d6d37c51824db461a2d6952d6af42..830873c9e4e8457314fe9ba5913a1bc179ba1b2e 100644 (file)
@@ -36,6 +36,12 @@ else
 SDL2_CONF_OPTS += --disable-sse
 endif
 
+ifeq ($(BR2_X86_CPU_HAS_3DNOW),y)
+SDL2_CONF_OPTS += --enable-3dnow
+else
+SDL2_CONF_OPTS += --disable-3dnow
+endif
+
 ifeq ($(BR2_PACKAGE_SDL2_DIRECTFB),y)
 SDL2_DEPENDENCIES += directfb
 SDL2_CONF_OPTS += --enable-video-directfb