pcre: bump to version 8.32
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 28 Dec 2012 02:07:36 +0000 (02:07 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 28 Dec 2012 15:53:39 +0000 (16:53 +0100)
Bump PCRE to version 8.32
Also add a patch to remove compatibility bits, fixing:
http://autobuild.buildroot.net/results/e380b838296c85ff9aeaec9fa088bded69670307/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pcre/pcre-no-compat.patch [new file with mode: 0644]
package/pcre/pcre.mk

diff --git a/package/pcre/pcre-no-compat.patch b/package/pcre/pcre-no-compat.patch
new file mode 100644 (file)
index 0000000..7099727
--- /dev/null
@@ -0,0 +1,31 @@
+Kill ABI compatibility bits, we don't need them.
+Fixes build failures on non-ELF (blackfin) targets.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura pcre-8.32.orig/pcrecpp.cc pcre-8.32/pcrecpp.cc
+--- pcre-8.32.orig/pcrecpp.cc  2012-12-28 08:32:10.193847937 -0300
++++ pcre-8.32/pcrecpp.cc       2012-12-28 08:32:26.924376180 -0300
+@@ -58,22 +58,6 @@
+ // Special object that stands-in for no argument
+ Arg RE::no_arg((void*)NULL);
+-// This is for ABI compatibility with old versions of pcre (pre-7.6),
+-// which defined a global no_arg variable instead of putting it in the
+-// RE class.  This works on GCC >= 3, at least.  It definitely works
+-// for ELF, but may not for other object formats (Mach-O, for
+-// instance, does not support aliases.)  We could probably have a more
+-// inclusive test if we ever needed it.  (Note that not only the
+-// __attribute__ syntax, but also __USER_LABEL_PREFIX__, are
+-// gnu-specific.)
+-#if defined(__GNUC__) && __GNUC__ >= 3 && defined(__ELF__)
+-# define ULP_AS_STRING(x)            ULP_AS_STRING_INTERNAL(x)
+-# define ULP_AS_STRING_INTERNAL(x)   #x
+-# define USER_LABEL_PREFIX_STR       ULP_AS_STRING(__USER_LABEL_PREFIX__)
+-extern Arg no_arg
+-  __attribute__((alias(USER_LABEL_PREFIX_STR "_ZN7pcrecpp2RE6no_argE")));
+-#endif
+-
+ // If a regular expression has no error, its error_ field points here
+ static const string empty_string;
index 9947c4b7939f019b97f126cd0c86935175665cce..9e27cb52c9b98cdb18e65009d89da3a62bc2dcf0 100644 (file)
@@ -4,7 +4,7 @@
 #
 #############################################################
 
-PCRE_VERSION = 8.31
+PCRE_VERSION = 8.32
 PCRE_SITE = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre
 PCRE_LICENSE = BSD-3c
 PCRE_LICENSE_FILES = LICENCE