gcc: remove the --with-pkgversion option from the ccache hash
authorArnout Vandecappelle <arnout@mind.be>
Sun, 4 Oct 2015 16:06:01 +0000 (17:06 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 4 Oct 2015 16:22:21 +0000 (18:22 +0200)
One of the gcc configure options that we hash for ccache is
--with-pkgversion which is set to something like Buildroot
2015.11-git-00426-ge7e7e4f - i.e., it will change with every buildroot
commit. That's obviously not wanted, so substitute this away.

Also add a \n to the printf so the output is a bit more readable.

[Peter: update documentation to match]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gcc/gcc.mk

index 420c4e9b7cb028c131216fb539397ef90d33d3b1..ead3e150c6563006c3e4e97d3cb04b07f4dbf71e 100644 (file)
@@ -256,10 +256,12 @@ HOST_GCC_COMMON_CCACHE_HASH_FILES += package/gcc/$(GCC_VERSION)/1000-powerpc-lin
 endif
 endif
 
-# _CONF_OPTS contains some references to the absolute path of $(HOST_DIR),
+# _CONF_OPTS contains some references to the absolute path of $(HOST_DIR)
+# and a reference to the Buildroot git revision (BR2_VERSION_FULL),
 # so substitute those away.
 HOST_GCC_COMMON_TOOLCHAIN_WRAPPER_ARGS += -DBR_CCACHE_HASH=\"`\
-       printf '%s' $(subst $(HOST_DIR),@HOST_DIR@,$($(PKG)_CONF_OPTS)) \
+       printf '%s\n' $(subst $(HOST_DIR),@HOST_DIR@,\
+               $(subst --with-pkgversion="Buildroot $(BR2_VERSION_FULL)",,$($(PKG)_CONF_OPTS))) \
                | sha256sum - $(HOST_GCC_COMMON_CCACHE_HASH_FILES) \
                | cut -c -64 | tr -d '\n'`\"
 endif # BR2_CCACHE